The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Article and Review System

Geek Article and Review System GARS is the mega popular system for turning forums into articles, tutorials, or even reviews.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 01-25-2006, 04:55 AM
JirQUEST JirQUEST is offline
Member
 
Join Date: Jan 2006
Posts: 47
Geek Article and Review System License Holder 
Default Something about ratings

i have a member who rated this certain article, with custom questions for the ratings. what happens is, the rating does not show up. instead, it says that "1 member has rated an average of 0%". and when i clicked on the link that says "i want to rate it", it popped up and gave me a window with the

Users Review - Close this window
Go Button

nothing else. there were no questions in it.

i went to the database and adjusted the values. the table is "gars". column is "ratings_data". i adjusted the value in it from a:0:{} to a:1:{}. the custom questions appeared fine when i refreshed the page.

i went to the database and searched "gars" for all data values of a:0:{}. i found that those with a:0:{}, regardless of whether anyone rated them or not, have the same problem.

also, i noticed that there are certain userid values at 1, which is mine. in those threads, there is no link to rate the article. those articles are not posted by me, merely edited.

i know for sure that the date of the last post does not matter to whether this bug recurs; however, i am unsure of the causes, but if anyone has any idea, please give a hint

and thanks for reading this long post


[edit]i noticed that all of the threads that have been edited before were affected. the userid becomes that of the person who edited it. the a:1:{} also reverts to a:0:{} when that happens.

Last edited by JirQUEST; 01-25-2006 at 05:29 AM..
Reply With Quote
  #2  
Old 01-25-2006, 06:09 AM
Lizard King's Avatar
Lizard King Lizard King is offline
Senior Member
 
Join Date: Oct 2005
Location: Istanbul
Posts: 555
Geek Article and Review System License Holder Geek Gazette License Holder 
Default

Currently i didn't check why but the person who last edited the article is turning to be the thread opener pratically thats why it is causing a problem with the rating system. My opinion this is happening because of post as other user option .
Reply With Quote
  #3  
Old 01-25-2006, 06:45 AM
JirQUEST JirQUEST is offline
Member
 
Join Date: Jan 2006
Posts: 47
Geek Article and Review System License Holder 
Default

i didnt check the codes to say for sure, but do u have any idea about the one with the a:0:{} data value? i clicked on the rating link after changing only the userid, and it still didnt work.
Reply With Quote
  #4  
Old 01-25-2006, 02:45 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

I dont think the problem is with the serialized values. In fact, editing those values can sometimes lead to really wonky results.
Now, im working from memory here so bear with me....

Where you want to look is possibly the gars_user_ratings table (or something like that).
I havent seen this and no one else has reported it, but it sounds like what lizard and you are getting at is that by using the post as or by editing someone elses review will make you the owner of the ratings?!? Is that what youre saying?

Thanks
Reply With Quote
  #5  
Old 01-25-2006, 02:56 PM
JirQUEST JirQUEST is offline
Member
 
Join Date: Jan 2006
Posts: 47
Geek Article and Review System License Holder 
Default

Quote:
Originally Posted by The Geek
I dont think the problem is with the serialized values. In fact, editing those values can sometimes lead to really wonky results.
Now, im working from memory here so bear with me....

Where you want to look is possibly the gars_user_ratings table (or something like that).
I havent seen this and no one else has reported it, but it sounds like what lizard and you are getting at is that by using the post as or by editing someone elses review will make you the owner of the ratings?!? Is that what youre saying?

Thanks
i am aware it might mess things up, but it seems to work, so i am not complaining.

there are 2 problems right now.

1) editing thread will insert your userid into gars table. thus, u cant vote on an article that's not submitted by u, though system still recognises the right user for the article (showthread is showing the correct author's name).

2) certain articles cant be rated - one of the problems is the user id, the other problem, which i corrected by changing the data value, is from the "ratings_data" column. i changed that from a:0:{} to a:1:{}...

like i said before, if i edited only the userid, it wont work. i still cant rate, and the pop-up will only show

Users Review - Close this window
Go Button

no rating questions shown. but if i edit the "ratings_data" column, it works immediately. if "ratings_data" has only a value of 0, nothing is affected. i hope that helps clear the air a bit.
Reply With Quote
  #6  
Old 01-25-2006, 03:29 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Thanks, it helps
Reply With Quote
  #7  
Old 01-25-2006, 03:34 PM
JirQUEST JirQUEST is offline
Member
 
Join Date: Jan 2006
Posts: 47
Geek Article and Review System License Holder 
Default

if u need an example, i can let u log in as an admin to get visuals of what i mean. i just need to adjust values in the database to get back the same problem.
Reply With Quote
  #8  
Old 05-01-2006, 01:19 AM
tormodg's Avatar
tormodg tormodg is offline
Member
 
Join Date: Sep 2005
Location: Oslo, Norway
Posts: 72
Geek Article and Review System License Holder Geek Advertising Banner License Holder 
Default

Quote:
Originally Posted by JirQUEST
i still cant rate, and the pop-up will only show

Users Review - Close this window
Go Button

no rating questions shown.
Sorry for bumping an old thread but this is what I get as well.
__________________
Hypography Science Forums
Reply With Quote
  #9  
Old 05-01-2006, 06:09 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

is it a review that you posted (or you used the 'post as') feature? Have you tried admincp/gars_admin.php?do=cleangars
Reply With Quote
  #10  
Old 05-01-2006, 06:35 PM
tormodg's Avatar
tormodg tormodg is offline
Member
 
Join Date: Sep 2005
Location: Oslo, Norway
Posts: 72
Geek Article and Review System License Holder Geek Advertising Banner License Holder 
Default

Hm. I wonder if it's a cache problem because today it works. Too late last night, perhaps.

But I have one issue left: I removed one of the questions from the survey. Now the responses for that question are left with a blank text but the point bar is still shown. Also, the survey forms still contain a dropdown box for that question, but no question text.

How do I "reset" this?
__________________
Hypography Science Forums
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ratings indie Geek Article and Review System 11 04-25-2007 10:02 PM
Star Ratings instead of Bar Ratings? rarara Geek Article and Review System 3 01-23-2007 02:03 PM
Ratings TTG Geek Article and Review System 15 08-24-2006 05:21 PM
Submit the above ratings (box must be ticked to save ratings) attroll Geek Article and Review System 1 06-04-2006 09:28 PM


All times are GMT. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.