The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Auto-Linker

Geek Auto-Linker GAL automatically links keywords that users type in posts to advertising hover pop-ups.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 12-03-2005, 04:04 PM
SpadMan's Avatar
SpadMan SpadMan is offline
Junior Member
 
Join Date: Nov 2005
Posts: 4
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Question Special Characters

I've created a standard link and the replacement text contains a standard entity reference (i.e. Small e, acute accent). I've tried each of the following in the replacement text field for the link but GAL doesn't appear to recognize them.

PHP Code:
é
é
&eacute
In fact, using the second value in the list above in the GAL replacement text field results in the following error when viewing posts.

Warning: preg_replace(): Unknown modifier '2' in /geek/ gal /includes/gal_class_core.php on line 178

Any suggestions on making this work would be much appreciated.
Reply With Quote
  #2  
Old 12-03-2005, 04:50 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

hmmm. check the source text... does it use the second option? If so, try &\#233;

The # is a special regexp character.

Let me know (the others should work - Im assuming the editor is using é )
Reply With Quote
  #3  
Old 12-03-2005, 05:35 PM
SpadMan's Avatar
SpadMan SpadMan is offline
Junior Member
 
Join Date: Nov 2005
Posts: 4
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

Your were correct. I forgot to use the backslash. Problem solved.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange characters error brasolino Geek Auto-Linker 24 01-06-2009 05:38 PM
Problem with Characters MrD Geek Auto-Linker 11 01-31-2008 05:11 PM
HTML special characters - $ and " being parsed to & and " rtysmith Geek Auto-Linker 8 01-29-2008 07:26 PM
Problem with german special Charakters darkdiver Geek Auto-Linker 10 04-23-2007 07:29 AM
Banner in special Forum not works MotMann Geek Advertising Banner System 5 09-13-2006 09:16 AM


All times are GMT. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.