The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Auto-Linker

Geek Auto-Linker GAL automatically links keywords that users type in posts to advertising hover pop-ups.

Advertisement
This is an HTML example. Isn't it just wonderful?!?!
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 05-19-2008, 11:56 PM
Frogger Frogger is offline
Junior Member
 
Join Date: Jan 2008
Posts: 8
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default I am stucked..

I have been trying to make Gal work for hours but cant make it work. I have read through the forum copied the setup from
http://www.thevbgeek.com/showthread.php?t=3934
http://www.thevbgeek.com/showthread.php?t=4158
and a couple of others with the same depressing result. I might be to tired even after 7 cups of coffee

At the moment I am willing to pay to have someone to set up Gal for me just so I can see how it should be done.. Could anyone help me?
Reply With Quote
  #2  
Old 05-20-2008, 12:39 AM
Lizard King's Avatar
Lizard King Lizard King is offline
Senior Member
 
Join Date: Oct 2005
Location: Istanbul
Posts: 555
Geek Article and Review System License Holder Geek Gazette License Holder 
Default

What is the problem you face.
Reply With Quote
  #3  
Old 05-20-2008, 02:20 AM
Frogger Frogger is offline
Junior Member
 
Join Date: Jan 2008
Posts: 8
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

Well, It installed fine, but I don't understand how I can make it auto link. Do I need to add any html code anywhere or does Gal as I suspect the job? If I let a non mod ore admin add keywords, where do they do that?

Anyway I did exactly as Morgan wrote in this post and tried what JustAskJulie did in this post with the exception that I added keywords.

Still the same problem.. nothing links
I suspect that I am doing something completely wrong and cause of an overdose of coffee are not able to see the error.
Reply With Quote
  #4  
Old 05-20-2008, 03:59 AM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

What did you enter in the Keywords box, does the keyword get &amped; in the HTML source of the webpage? If so, see this thread. Does the keyword in the HTML source appear between other HTML tags like <font> or <b> or <i> etcetera? If so, GAL tends not to link those keywords in order to avoid messing up the HTML, though you can set a different regular expression if you want. Also, make sure the Auto Link is set to yes, and under Categories, use gal_link_popup in the Links column and use gal_content_popup_rounded in the Content column to get the pop-up to display like on this site.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #5  
Old 05-20-2008, 09:27 AM
Frogger Frogger is offline
Junior Member
 
Join Date: Jan 2008
Posts: 8
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

the html source looks like this:
Code:
<!-- message -->
		<div id="post_message_6">Test.. . klovn, klovnefisk, korall *korall /w klown fisk fisker<!-- GAL --></div>
		<!-- / message -->
Quote:
Originally Posted by Morgan View Post
Also, make sure the Auto Link is set to yes, and under Categories, use gal_link_popup in the Links column and use gal_content_popup_rounded in the Content column to get the pop-up to display like on this site.
As far as my tired eyes can see Aut Link is set to yes.

Last edited by Frogger; 05-20-2008 at 06:32 PM..
Reply With Quote
  #6  
Old 05-21-2008, 06:19 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

What is the keyword that is supposed to be auto-linked in that message? Is that keyword in the keywords box in the ACP -> GAL -> Display -> click a keyword -> look at 'Keywords (comma delimited)' box?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #7  
Old 06-10-2008, 07:25 PM
nima's Avatar
nima nima is offline
Junior Member
 
Join Date: Jun 2008
Posts: 10
Geek Auto-Linker Pro License Holder 
Default

i have the same problem. My keyword is set to "Starbuzz Tobacco" and I have the URL field set, and have the campaign set on "Active"

but it doesnt work (ex: here)
Reply With Quote
  #8  
Old 06-10-2008, 07:49 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Double check the following items and make sure that 'Auto Link' is set to yes for that keyword.

Go to the ACP -> Geek Auto-Linker -> Categories, and for each category, make sure all 'Forums' are checked and all 'Usergroups exempt from category' are unchecked.

Go to the ACP -> Geek Auto-Linker -> Categories, and for each dictionary, make sure all 'Usergroups that can view entries' are checked.

Go to the ACP -> Geek Auto-Linker -> Permissions, and for each usergroup and each dictionary, set the permissions as you prefer.

Go to the ACP -> Geek Auto-Linker -> Display, and for each keyword, make sure all 'Auto-link' are checked and the status is active.

Go to the ACP -> Geek Auto-Linker -> Maintenance, and run the two 'Cache' options.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #9  
Old 06-10-2008, 08:11 PM
nima's Avatar
nima nima is offline
Junior Member
 
Join Date: Jun 2008
Posts: 10
Geek Auto-Linker Pro License Holder 
Default

I just did all of those and still no change....
Reply With Quote
  #10  
Old 06-10-2008, 08:21 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Check that Status is set to Active for the keyword. Double check that 'Auto Link' is set to yes for the keyword.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.