The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Article and Review System

Geek Article and Review System GARS is the mega popular system for turning forums into articles, tutorials, or even reviews.

Advertisement
This is an HTML example. Isn't it just wonderful?!?!
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 01-06-2008, 08:14 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default Upgrading Problems with Control Panel and Showthread

Hi! I just upgraded from 2.1.4 to 2.1.8. Everything seems to have gone okay with two serious exceptions:

1. I cannot access the GARS control panel via AdminCP -- when I try, I'm told I don't have permission to access the administrative controls on this page.

2. Two of my most important forums are appearing blank. I can see the individual threads if I go to them from a direct URL, but if I try to view the thread list (showthread?), the entire page is blank. I have no idea why or how to fix it. Other forums using GARS are displaying the thread list fine. So maybe a style problem, as the two problem forums use a different style. There's another forum using GARS that uses the same style, but its working fine. The difference is that the two problem forums are using a different GARS "type" (Download Type) than the one that is working.

Please help! Thanks!

Last edited by Jennifer Marx; 01-06-2008 at 08:20 PM..
Reply With Quote
  #2  
Old 01-06-2008, 08:21 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

1) Give yourself permission (Usergroups -> Administrator Permissions -> Edit Permissions -> Can Administer GARS -> Yes)

2) Under Types check the Template Set and see if those template in that set exist. Also please note the comment on this page:
Quote:
Your custom templates and phrases for GARS add ons (i.e. the link directory and/or the release add on) will get wiped out. After upgrading you will need to use the GARS importer to re-import the add ons (making sure you choose the option to import phrases.templates only).
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #3  
Old 01-06-2008, 08:26 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default

Update: I logged in with my alternate admin account and was able to access the GARS control panel (but I don't understand the problem with my main admin account). Once I could get into the control panel, I made a brand new test forum then assigned it to the GARS Download Type. Sure enough, it displays as blank. So I guess there's a problem with the Download Type? It uses the File term set, the Default template set, and the Download module. There's nothing weird about it so far as I can tell.
Reply With Quote
  #4  
Old 01-06-2008, 08:31 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default

Quote:
Originally Posted by Morgan View Post
1) Give yourself permission (Usergroups -> Administrator Permissions -> Edit Permissions -> Can Administer GARS -> Yes)
I looked here, but I don't have the "Can Administer GARS" option for the admin account I use most. Just in case I was missing it, I made sure every option was set to Yes. Didn't work. Logged out and back in again. Still doesn't work. Oddly enough, I don't see that option under my more powerful admin account either, yet it can use the GARS control panel.

Quote:
2) Under Types check the Template Set and see if those template in that set exist. Also please note the comment on this page:
Yes, it's the Download Type, and it uses the Default Set of templates.
Reply With Quote
  #5  
Old 01-06-2008, 08:37 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Is your admin account in the Administrator usergroup? What templates do you have listed in the Default Set Template Set?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #6  
Old 01-06-2008, 08:40 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default

Yes, both admin accounts I'm referring to are in the Administrator usergroup.

The templates listed in the Default Set are just Default Set. I checked before the upgrade to make sure I had no other sets besides the default, and I did not.
Reply With Quote
  #7  
Old 01-06-2008, 08:42 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default

When I click edit on the Default set, this is what I see:

Title: Default Set
Forumdisplay: GARS_forumdisplay
threadbit: GARS_threadbit
Deleted threadbit: GARS_threadbit_delete
showthread: (empty)
First post in showthread: GARS_pb
First post preview on additional pages: (empty)
Comments: GARS_comment
Deleted comments: (empty)
New Thread: (empty)
Edit Thread: (emtpy)
Reply With Quote
  #8  
Old 01-06-2008, 08:48 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default

Update: I solved the problem with the admin account not accessing the GARS control panel by making it a superadminstrator. Not sure if this is a feature or a bug.

Still trying to figure out the blank forum problem.
Reply With Quote
  #9  
Old 01-06-2008, 08:55 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Strange, try switching the two problem forums to have the same style as the forums that work. If they still do not display, try switching from download type to another type for those two forums and see what happens. I don't know why you cannot see the "Can Administer GARS" option as that is being generated from a plugin.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #10  
Old 01-06-2008, 09:20 PM
Jennifer Marx Jennifer Marx is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Geek Article and Review System License Holder 
Default

Switching styles makes no difference. Switching types works, and they will display, but that type isn't what I need -- I really need the Download Type to work on those forums as it is counting the number of members who downloaded a particular file.

The Download Type doesn't work regardless of which forum I put it on, nor which style I set the forum to display. How can I fix the Download Type?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No GARS Admin panel? unenergizer Geek Article and Review System 4 01-17-2007 07:04 PM
Needs Better Frequency Control lars Geek Advertising Banner System 1 11-04-2006 01:17 AM
GAL permission control natas Geek Auto-Linker 4 10-06-2006 04:36 PM
stock control? CAMS GeekMart 2 03-22-2006 11:03 PM
[not a bug]Now where is the GAB control panel gone Hanif Geek Advertising Banner System 2 10-20-2005 06:48 AM


All times are GMT. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.