The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Article and Review System

Geek Article and Review System GARS is the mega popular system for turning forums into articles, tutorials, or even reviews.

Advertisement
This is an HTML example. Isn't it just wonderful?!?!
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 01-02-2008, 07:19 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default Upgrade problem

I have just updated to the latest version, and now some images are broken and when I try to read one of my tutorials I get the following message.

Fatal error: Cannot redeclare gars_full_httpit() (previously declared in D:\inetpub\vhosts\vistax64.com\httpdocs\geek\gars\ mods\display\custom_fields.php:26) in D:\inetpub\vhosts\vistax64.com\httpdocs\geek\gars\ mods\display\custom_fields.php on line 33

www.vistax64.com/tutorials/

Ideas?
Reply With Quote
  #2  
Old 01-02-2008, 07:33 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Grab the package again and FTP two files:
  • /geek/gars/mods/display/custom_fields.php
  • /geek/gars/includes/gars_custom_fields_edit.php
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #3  
Old 01-02-2008, 07:49 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default

Great that fixed most of it, but I still have the problem with some broken images and some odd adsense code around the title.

<!-- google_ad_section_start -->

http://www.vistax64.com/tutorials/62...-problems.html
Reply With Quote
  #4  
Old 01-02-2008, 07:55 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default

Also the "read more" gmore.gif is missing from the synopsis on the forumdisplay
Reply With Quote
  #5  
Old 01-02-2008, 08:07 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default

The <!-- google_ad_section_start --> tags wrapped around the titles of the posts with broken header images, seems to be a conflict with vbseo's AdSense targeting, I have turned it off and the tags disappeared.
Reply With Quote
  #6  
Old 01-02-2008, 08:36 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default

From what I can see the problem with the broken images seems to be with the formating of the image url when the image name has a space in it.

Gars is showing the image location as:-
http://www.vistax64.com/geek/gars/im...igurations.png - Broken

But the file shows if I change the + in the url
http://www.vistax64.com/geek/gars/im...igurations.png - Works
Reply With Quote
  #7  
Old 01-02-2008, 09:03 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Grab the package again and FTP these files:
  • /admincp/gars_admin.php
  • /geek/gars/includes/gars_class_edit.php
  • /geek/gars/includes/gars_class_list.php
  • /geek/gars/includes/gars_class_page.php
  • /geek/gars/includes/gars_custom_fields_edit.php
  • /geek/gars/includes/gars_custom_fields_save.php
  • /geek/gars/mods/display/custom_fields.php
  • /geek/gars/mods/display/featured.php
  • /geek/gars/mods/display/linkheaderimage.php
  • /geek/gars/mods/display/marked.php
What's a link to the missing more image?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #8  
Old 01-02-2008, 09:07 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default

Quote:
Originally Posted by Morgan View Post
Grab the package again and FTP these files:

What's a link to the missing more image?
The broke more image was pointing to vistax64.com/images/tealblack/misc/gmore.gif


I just copied the one from your misc folder to that location to fix it.

Thanks
Reply With Quote
  #9  
Old 01-02-2008, 09:12 PM
z3r010's Avatar
z3r010 z3r010 is offline
Junior Member
 
Join Date: May 2007
Posts: 24
Geek Article and Review System License Holder 
Default

Nope the images are still broken

http://www.vistax64.com/tutorials/index32.html
Reply With Quote
  #10  
Old 01-02-2008, 09:25 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Looks like you've already replaced the image with a non-space filename. New uploads with spaces should hopefully be okay, and all places where + appeared have been replaced with %20 instead. Double check that all files listed in post seven overwrote the old files on the server, and if you still have problems with filenames with spaces, just let me know. Oh, if I would have used %20 from the start.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Encoding problem after upgrade Bellinis Geek Auto-Linker 2 03-03-2008 08:55 AM
Upgrade Problem soultrader Geek Article and Review System 8 06-05-2007 06:50 PM
problem: admin invisible after upgrade magnaromagna Geek Auto-Linker 2 04-25-2007 02:11 PM
module edit problem after upgrade Grae Geek Article and Review System 1 06-15-2006 07:13 AM
possible forum problem with upgrade? GoTTi GeekMart 5 09-13-2005 04:32 PM


All times are GMT. The time now is 11:41 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.