The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Article and Review System

Geek Article and Review System GARS is the mega popular system for turning forums into articles, tutorials, or even reviews.

Advertisement
This is an HTML example. Isn't it just wonderful?!?!
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 06-24-2007, 09:22 PM
pipin pipin is offline
Member
 
Join Date: Dec 2006
Posts: 35
Geek Article and Review System License Holder 
Default New module blocks out guests

I just created a new module for displaying ads just beneath the articles and it works as wanted, but guests are blocked out with the message:

Unable to add cookies, header already sent.

Code:
Datei: $filename vbulletin/geek/gars/mods/display/ad_one.php
Zeile: $linenum 12
the php file:

Code:
<?PHP 

	    $bits="<tr><td align=\"center\">";
	    $p3d_ourbanner_artikel = file_get_contents('leadpartner.txt');
	    $bits.=$p3d_ourbanner_artikel;
	    $bits.="</td></tr>";
	    $title="Werbung";
	    eval('$output.="' . fetch_template('GARS_mod_container') . '";');
?>

The module caches the template GARS_mod_container and is added to the Default Module Set.

As said it works for everyone except guests. but if you log in and log out then it works too. Just running out of ideas what could be the cause.
Reply With Quote
  #2  
Old 06-25-2007, 01:09 AM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Sounds to me like an error with the code (i.e. the file_get_contents). They are getting an error that gets sent to the client before the cookies do.
Reply With Quote
  #3  
Old 06-25-2007, 05:49 AM
pipin pipin is offline
Member
 
Join Date: Dec 2006
Posts: 35
Geek Article and Review System License Holder 
Default

Quote:
Originally Posted by The Geek View Post
Sounds to me like an error with the code (i.e. the file_get_contents). They are getting an error that gets sent to the client before the cookies do.
Was my first guess, too. But even letting out the 2nd and 3rd line won't change the behaviour.

as a workaround i added the code to the toc.php and this works.

Last edited by pipin; 06-25-2007 at 06:00 AM..
Reply With Quote
  #4  
Old 06-25-2007, 09:27 AM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

If youre looking to display adsense, my suggestion is to use the Template Module add on in the add ons forum. That is the easiest way to configure it
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Links and Overlays for Guests? ruhrpottforum Geek Auto-Linker 1 06-28-2008 06:48 PM
GAL links *only* to guests djr Geek Auto-Linker 1 01-29-2008 07:14 PM
Show Links to guests Nick0r Geek Auto-Linker 7 09-05-2007 04:19 PM
sides blocks efil Geek Article and Review System 2 03-24-2007 05:36 AM
No link for guests misterserveur Geek Auto-Linker 1 11-24-2006 10:50 PM


All times are GMT. The time now is 10:24 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.