The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Auto-Linker

Geek Auto-Linker GAL automatically links keywords that users type in posts to advertising hover pop-ups.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 03-15-2007, 01:02 PM
MrD MrD is offline
Member
 
Join Date: Oct 2006
Posts: 52
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default Problem with Characters

Hi,
i used GAL in German but i have a Problem with following words.

I set gtue,gtü in a gal and tuev,tüv

But if i wrote in my postings gtü GAL do not work.
gtue,tüv,tuev works correctly.

only gtü is not shown as a gal
Reply With Quote
  #2  
Old 03-15-2007, 02:11 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

what version?
Reply With Quote
  #3  
Old 03-15-2007, 06:33 PM
MrD MrD is offline
Member
 
Join Date: Oct 2006
Posts: 52
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Hi,
Version is 4.81.

but if i change the word gtü to güt, gal works.

Last edited by MrD; 03-15-2007 at 07:03 PM..
Reply With Quote
  #4  
Old 03-15-2007, 08:58 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Double check the source code and see if vB is changing the character to its HTML equivilent.
Reply With Quote
  #5  
Old 03-15-2007, 10:06 PM
MrD MrD is offline
Member
 
Join Date: Oct 2006
Posts: 52
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Hi,
i Think it´s an error in the Scriptcode.
If the Special Charater Ü Ö Ä are in the middle of the Word, gal works, are they at the begining or end of the word, gal do not work correctly.

On the screenshot are my code.
in cached regex
Code:
#(\b((?<=\s|"right">|"left">|"center">|<li>|<span class="highlight">|<strong>|<b>|<i>)(?<!GAL--> )(gtue|gtü))s?\b)#im
and

Code:
<a href='http://www.opel-problemforum.de/autolink.php?id=34{TRACK_HITS}' target='_blank' class='gal' onmouseover='GAL_popup(this,"1", 300, "style=\"border: 1pt solid #000000;\"", "<!--GAL-->Eine <!--GAL-->sehr <!--GAL-->kompetente <!--GAL-->Prüforganisation", "style=\"background: #FFFFCC;padding: 2px;font-size: 10px;\"", "<!--GAL-->GTÜ", "style=\"border-top: 1px solid black;border-bottom: 1px solid black;background: #CCCCCC;padding: 1px;font-size: 10px;font-weight: bold;color: #000000;\"");' onmouseout='GAL_hidepopup();'><!--GAL-->$1</a>
Attached Images
File Type: jpg code.jpg (29.5 KB, 8 views)

Last edited by MrD; 03-15-2007 at 10:27 PM..
Reply With Quote
  #6  
Old 03-16-2007, 12:05 AM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

They could be being seen as word boundaries - however have you checked the source code yet to see if vB is translating the text into html entities?
Reply With Quote
  #7  
Old 03-22-2007, 07:38 AM
millionart millionart is offline
Junior Member
 
Join Date: Mar 2007
Posts: 2
Default

If I wrrite Chinese or Japanese and the other utf-8 Charater,the GAL cant work.
Is it a bug?
How to Fix it by myself?
Thanks for your help
Reply With Quote
  #8  
Old 03-22-2007, 10:31 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Youre not showing up as licensed
Reply With Quote
  #9  
Old 03-23-2007, 01:12 AM
millionart millionart is offline
Junior Member
 
Join Date: Mar 2007
Posts: 2
Default

yeah,I used the crack file for localhost testing and find this bug,I want to know whether it be fixed in v5.0 beta?
I like this mod and it really looks very cool.
If u say yes,I must buy it.
Then I can help u for the chinese language file if u want that.
thanks for reply ^_^

Last edited by millionart; 03-23-2007 at 01:18 AM..
Reply With Quote
  #10  
Old 03-25-2007, 12:09 PM
MrD MrD is offline
Member
 
Join Date: Oct 2006
Posts: 52
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Hi,
in normal threads, the words with öäü at the beginning/End will correctly displayed.

only gal makes an error.

if i put &Uuml behind GT it will work correctly.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with greek characters lthanos Geek Article and Review System 3 12-29-2009 08:47 AM
Strange characters error brasolino Geek Auto-Linker 24 01-06-2009 05:38 PM
Problem with some norwegian characters in GAL Frogger Geek Auto-Linker 1 07-09-2008 02:36 PM
Problem with Turkish Characters batox Geek Auto-Linker 4 02-09-2008 08:07 PM
Special Characters SpadMan Geek Auto-Linker 2 12-03-2005 05:35 PM


All times are GMT. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.