The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Article and Review System

Geek Article and Review System GARS is the mega popular system for turning forums into articles, tutorials, or even reviews.

Advertisement
This is an HTML example. Isn't it just wonderful?!?!
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 11-28-2006, 12:25 AM
autopia's Avatar
autopia autopia is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default Image upload issue

I looked high and low and found this problem, but not a resolution that solves the issue for me. Here's the error message:

Quote:
Got some freaky error while moving file from /tmp/phpWYxiTD to /home/httpd/vhosts/autopia.org/httpdocs/forum/geek/gars/images/6/9/argue.gif. Upload fine. Move=problem. error? #0
I ran "chmod -R /images" and veified that all files/folders have the correct permission.

safe_mode is OFF and so is the GARS safe_mode parameter.

I triple checked my directory and URL settings for GARS and they are correct.

What could I be missing?

Thanks,
db
Reply With Quote
  #2  
Old 11-28-2006, 07:36 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Is the file created? Is it happening on all images or one in particular.

Also, make sure that your path is the correct case. On some servers, a mixed case path will cause this.
Reply With Quote
  #3  
Old 11-29-2006, 05:24 PM
autopia's Avatar
autopia autopia is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Yes, the file does exist and it happens with any pic you try to upload.

I verified path case (did a direct cut/paste from pwd command while in the directory).

I looked in /tmp to see if the file is left behind, but it isn't. Can't verify that it ever gets uploaded. I have other php based apps that use /tmp for file upload and they are working okay.

Reply With Quote
  #4  
Old 11-29-2006, 09:04 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

The upload is working, but the script is having a problem copying the image to the new folder. Is the folder there (i.e. the path is valid but no pic?)
Reply With Quote
  #5  
Old 11-29-2006, 10:32 PM
autopia's Avatar
autopia autopia is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Quote:
Originally Posted by The Geek
The upload is working, but the script is having a problem copying the image to the new folder. Is the folder there (i.e. the path is valid but no pic?)
Yes, I just verified again that the path is valid and permission all the way through is 777.
Reply With Quote
  #6  
Old 11-29-2006, 10:59 PM
autopia's Avatar
autopia autopia is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

I spoke too soon... it looks like PhotoPost is having the same problem with picture uploads.

directories and sub directories are set to 777
safe mode is OFF
php file upload is on
file upload size set to 8MB

What could I be missing?
Reply With Quote
  #7  
Old 11-30-2006, 07:56 AM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

What about vb and attachments (if they are stored in the file system)
Reply With Quote
  #8  
Old 11-30-2006, 05:33 PM
autopia's Avatar
autopia autopia is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Problem solved.

At the Linux hell prompt pwd showed the path as:

/home/httpd/vhosts/autopia.org...

PHPINFO() shows the path as:

/var/www/vhosts/autopia.org...

phpinfo() is your friend!
Reply With Quote
  #9  
Old 11-30-2006, 09:50 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Thats great news. Thanks!
Reply With Quote
  #10  
Old 12-09-2006, 10:42 AM
Asasi Asasi is offline
Junior Member
 
Join Date: Jun 2006
Posts: 25
Geek Article and Review System License Holder 
Default

I have the same error:
Got some freaky error while moving file from /tmp/phpS7np0k to /home/ziafatco/public_html/forums/geek/gars/images/3invincible2.jpg. Upload fine. Move=problem. error? #0

safe_mode is on and enabled in gars settings. path is true. file will upload but with 0 Byte of size!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can not upload header image stckhlm Geek Article and Review System 7 10-23-2008 06:38 PM
Limit file upload size (Thumbnail to original image upload) -RL- Geek Article and Review System 1 03-24-2008 05:25 PM
Another image issue indie Geek Article and Review System 2 03-04-2007 12:43 PM
Yet another image issue... Kingster Geek Article and Review System 9 01-02-2007 08:40 AM
Only admin can upload image Bashy Geek Article and Review System 5 09-08-2006 12:52 PM


All times are GMT. The time now is 08:30 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.