The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Article and Review System

Geek Article and Review System GARS is the mega popular system for turning forums into articles, tutorials, or even reviews.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 02-09-2006, 09:52 AM
beernuts beernuts is offline
Junior Member
 
Join Date: Feb 2006
Posts: 10
Geek Article and Review System License Holder 
Default Member's ratings won't save when posting a comment.

Howdy Geek (et. al.),

I'm trying to set up my review system, and it's all going fairly smoothly save for one problem. When I try to submit a comment, and then set the various ratings, the comment will post just fine, but the ratings won't save. If I then go to edit that post, all the ratings are set at zero. I can try changing them a million times, and they won't save. Oddly enough, if I click the "I want to rate it!" link in the Members' ratings box, I can then rate the product, and that rating will 'save', and show up in the post.

Any thoughts?

Thanks much,

-Nick
Reply With Quote
  #2  
Old 02-09-2006, 01:08 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Are you working on a modified style? If so, can you test on a default style?
Reply With Quote
  #3  
Old 02-09-2006, 07:35 PM
beernuts beernuts is offline
Junior Member
 
Join Date: Feb 2006
Posts: 10
Geek Article and Review System License Holder 
Default

Quote:
Originally Posted by The Geek
Are you working on a modified style? If so, can you test on a default style?
TG,

It's a default style.

-Nick
Reply With Quote
  #4  
Old 02-10-2006, 01:21 AM
cmiller1014 cmiller1014 is offline
Member
 
Join Date: Aug 2005
Posts: 39
Geek Auto-Linker Pro License Holder 
Default

Mines the default style too, tons of problems with gars. Ratings dont work - period. Worked once, now dead.
Reply With Quote
  #5  
Old 02-10-2006, 02:10 AM
beernuts beernuts is offline
Junior Member
 
Join Date: Feb 2006
Posts: 10
Geek Article and Review System License Holder 
Default

TG,

Another thing I noticed. Not only will the comment button not add members' ratings, if a member adds a rating by clicking the "I want to rate it!" link (which works fine), and then posts a comment (or does it in the opposite order), if they then try to edit their post, and change the way they voted, that doesn't save the results either.

Lastly, in posts, the width of the right column is not fixed, where would I change this?

(If you want me to send you a link or any other information, let me know or PM me, and I'll gladly do so).

Other than the quirk with members' reviews, and the column width thing, everything is working great!

Thanks much,

-Nick
Reply With Quote
  #6  
Old 02-10-2006, 03:22 AM
JirQUEST JirQUEST is offline
Member
 
Join Date: Jan 2006
Posts: 47
Geek Article and Review System License Holder 
Default

to further comment on this issue,

i require my members to submit articles on a non-gars forum. i edit the articles and transfer them to a gars forum. not sure if this affects the ratings in any way, but here is how the process goes:

edit article (non-gars) -> transfer (gars) -> comment -> rate -> rating not turning up.

checked gars table using threadid. search turns up nothing.

edit article again (gars) -> no link to rate.

thread turns up in gars table in my search this time. but the "avg_rating_data" column is empty, and the userid becomes mine (simply because i edited the post). have to change both just to see the rating.

gripe: this is getting very frustrating. i managed to replicate the error twice, so i am pretty sure it will keep happening.
Reply With Quote
  #7  
Old 02-10-2006, 05:05 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

cmiller: Tested yours today and works fine as far as I can see.
Beer- If there is any way you can PM me an admincp url and account Ill check into it for you
jIRQuest. Hmmm. Interesting. I suppose that it wouldn't work because there will not be an entry point into the GARS table for the thread. Maybe I need to try and hook into thread moves too
There is a current issue where editing the thread does put your userid in as owner which is what is preventing you from rating. Can you try to edit it and use the post as feature to enter the original authors name? THis bug is in the current fix list and will be resolved shortly.

On a side note, can I ask why you just dont set those forums to be moderated? Seems like it would be easier?

Thanks guys
Reply With Quote
  #8  
Old 02-11-2006, 01:10 AM
cmiller1014 cmiller1014 is offline
Member
 
Join Date: Aug 2005
Posts: 39
Geek Auto-Linker Pro License Holder 
Default

Quote:
Originally Posted by The Geek
cmiller: Tested yours today and works fine as far as I can see.
Tested again myself today and its not working. Make sure your usergroup is "Distributor" on my forum. That might have something to do with it. A bulk of my members are in that group.

Thanks! I really like these scripts.
Reply With Quote
  #9  
Old 02-11-2006, 09:51 AM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

it wouldn't be usergroup specific. I suspect the reviews were created and saved when no review was attached or something similar. Choosing edit then save sorted it out
Reply With Quote
  #10  
Old 02-11-2006, 03:16 PM
JirQUEST JirQUEST is offline
Member
 
Join Date: Jan 2006
Posts: 47
Geek Article and Review System License Holder 
Default

Quote:
Originally Posted by The Geek
cmiller: Tested yours today and works fine as far as I can see.
Beer- If there is any way you can PM me an admincp url and account Ill check into it for you
jIRQuest. Hmmm. Interesting. I suppose that it wouldn't work because there will not be an entry point into the GARS table for the thread. Maybe I need to try and hook into thread moves too
There is a current issue where editing the thread does put your userid in as owner which is what is preventing you from rating. Can you try to edit it and use the post as feature to enter the original authors name? THis bug is in the current fix list and will be resolved shortly.

On a side note, can I ask why you just dont set those forums to be moderated? Seems like it would be easier?

Thanks guys
yeah. i recognised that after doing some thinking about why it isnt searchable from the gars table. cant exactly say it's a bug since it was never programmed in; and since there was never an entry point, rating it is like walking into a swimming pool with no water :P

anyway, i tried what u suggested. it doesnt work.

the reason why i dont set that forum to moderation is because, a lot of members on my site are not tech savvy. they end up wondering what happened to the thread, and why it isnt visible to them. saves me time explaining, and not writing it into the faq, which a lot of people never read anyway.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
member ratings indie Geek Article and Review System 5 02-20-2007 09:15 AM
member ratings problem Michelle Geek Article and Review System 6 10-20-2006 04:52 PM
Member Ratings convergent Geek Article and Review System 1 06-12-2006 07:08 PM
Submit the above ratings (box must be ticked to save ratings) attroll Geek Article and Review System 1 06-04-2006 09:28 PM
N/A not available in comment ratings germanspec330i Geek Article and Review System 5 03-18-2006 09:10 AM


All times are GMT. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.