The vB Geek

Go Back   The vB Geek > vB Geek Products > GeekMart

GeekMart GMart is an integrated shopping cart system for vBulletin.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2007, 09:32 PM
DMH DMH is offline
Junior Member
 
Join Date: Aug 2006
Posts: 26
Geek Article and Review System License Holder GeekMart License Holder Geek Advertising Banner License Holder 
Default 404 Not Found

I’m getting an error when I click on the return to merchant link on my paypal site. Any idea were it's getting the "/us/cgi-bin/" from?


Quote:
edited

Last edited by DMH; 08-14-2007 at 12:01 AM..
Reply With Quote
  #2  
Old 07-15-2007, 11:53 PM
Mythotical Mythotical is offline
Senior Member
 
Join Date: Nov 2005
Location: USA
Posts: 204
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

Check your paypal, make sure the return link for your IPN is set to the correct link, also check your GM settings and make sure you didn't accidentally put us/cgi-bin/ in there, as well drop public_html from your link.
__________________
Please use the Bug Tracker to report any bugs or possible problems.
ThevBCoder.com - The site that brings you scripts that give you 'It!'.

My trip to AZ was a success
Reply With Quote
  #3  
Old 07-16-2007, 02:10 AM
DMH DMH is offline
Junior Member
 
Join Date: Aug 2006
Posts: 26
Geek Article and Review System License Holder GeekMart License Holder Geek Advertising Banner License Holder 
Default

Myth, thanks for the fast reply. Looking into my IPN, what would my "Notification URL" be or how would I go about finding it?
Reply With Quote
  #4  
Old 07-16-2007, 05:19 AM
Mythotical Mythotical is offline
Senior Member
 
Join Date: Nov 2005
Location: USA
Posts: 204
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

It should be geekmart .php?do=ipn or similar, you can find it in your GM settings, where it says geekmart .php?do=success, find out for sure what the link should be then replace after = with ipn.

Sorry, I was on the phone for too long so I didn't get to reply sooner.
__________________
Please use the Bug Tracker to report any bugs or possible problems.
ThevBCoder.com - The site that brings you scripts that give you 'It!'.

My trip to AZ was a success
Reply With Quote
  #5  
Old 07-17-2007, 11:05 PM
DMH DMH is offline
Junior Member
 
Join Date: Aug 2006
Posts: 26
Geek Article and Review System License Holder GeekMart License Holder Geek Advertising Banner License Holder 
Default

Still no luck. Also, when I'm testing in my sandbox account and I complete the payment and should be taken to the success page, my paypal sandbox address is added to the beginning of my success page address. I've checked my Return URL on my account and it's the same address to my success page. For some reason links and addresses from paypal to my site are getting things added to the beginning of them.

Any ideas?
Reply With Quote
  #6  
Old 07-17-2007, 11:57 PM
Mythotical Mythotical is offline
Senior Member
 
Join Date: Nov 2005
Location: USA
Posts: 204
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

Sounds like you might have http://www.yourdomain.com/geekmart.php?do= added to your settings. Double check your settings. If you need further assistance after this then you can set me up a temp admin account where I can double check your settings.
__________________
Please use the Bug Tracker to report any bugs or possible problems.
ThevBCoder.com - The site that brings you scripts that give you 'It!'.

My trip to AZ was a success
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Page not found clearchannel Geek Auto-Linker 6 02-05-2008 01:51 AM
Bugs I've found in GeekMart KenDude GeekMart 4 02-04-2008 08:19 AM
Fatal error: Class 'geek_Upload_Image' not found JohnBee Geek Article and Review System 17 07-12-2007 08:07 AM
I found this, what do i do about it? joh Geek Advertising Banner System 9 02-12-2007 05:41 PM


All times are GMT. The time now is 11:54 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.