The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Auto-Linker

Geek Auto-Linker GAL automatically links keywords that users type in posts to advertising hover pop-ups.

Advertisement
This is an HTML example. Isn't it just wonderful?!?!
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 03-07-2008, 11:15 AM
za4a tuner za4a tuner is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder 
Default [GAL] Image-Upload failed -> Safe_Mod_on

Hello,
i have some trouble by uploading images to GAL .

My server where the forum is hosted uses php5.2.5-0.dotdeb.2 and mysql5.0.51a-0.dotdeb.1-log (php-info)

In the vBulletin-settings the safemod is set to yes -> and the tmp-path (/var/www/web27/html/forum/tmp) is set correct (attachement and avatar upload is OK).
When i try to activate at the GAL -Settings the safe_mod (Thumbnails -> Safe mod on? ->) to YES ... after safing the settings it turns back to NO!

When i try to upload an image the following error-message appears:
Quote:
Warning: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid is 686 is not allowed to access /var/www/web27/html/forum/geek/gal/images/1 owned by uid 33 in /geek/gal/includes/gal_functions_image.php on line 263
The folders -> images, 1 and 4 are chmoded to 777


Why does it not work?
__________________
sorry for my bad english ... my german is much better

Last edited by za4a tuner; 03-07-2008 at 11:17 AM..
Reply With Quote
  #2  
Old 03-07-2008, 01:41 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Grab the GAL package again, reFTP the gal_admin.php file into the /forum/admincp directory, and then in the GAL ACP settings, set 'Safe mode on' to yes and it'll stick.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #3  
Old 03-08-2008, 08:05 AM
za4a tuner za4a tuner is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder 
Default

Thanks for the repack,
no the settings are OK, but the upload still doesn't work.

I get the following message when i try to upload an image:
Quote:
1. Got some freaky error while moving file.
Any help for this?


kr Chris
__________________
sorry for my bad english ... my german is much better
Reply With Quote
  #4  
Old 03-09-2008, 10:35 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

In the gal_functions_image.php file find:
Code:
					if (!move_uploaded_file($file['tmp_name'], $dest))
                			{
						@unlink($file['tmp_name']);
                        		$errors[] = "Got some freaky error while moving file.";
                        		return;
                			}
And beforehand add:
Code:
					ini_set('display_errors', true);
					error_reporting(E_ALL);
					move_uploaded_file($file['tmp_name'], $dest);
Then try another upload and copy-paste any PHP message you see on screen.

Afterwards you can undo that edit.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #5  
Old 03-10-2008, 07:28 AM
za4a tuner za4a tuner is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder 
Default

I did the edits, tried a new upload => but there are no php-errors shown!
The upload failed again ... the errormessage is the same as i posted before:
Quote:
1. Got some freaky error while moving file.
__________________
sorry for my bad english ... my german is much better
Reply With Quote
  #6  
Old 03-10-2008, 02:23 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Are you sure /var/www/web27/html/forum/tmp is correct? When I go to http://www.your-domain.de/forum/tmp/ I get a 404 not found message. Perhaps you need to use /var/www/web27/html/tmp instead and set the directory permissions so that http://www.your-domain.de/tmp/ does not generate a 403 forbidden message.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #7  
Old 03-12-2008, 09:12 AM
za4a tuner za4a tuner is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder 
Default

Quote:
Originally Posted by Morgan View Post
Are you sure /var/www/web27/html/forum/tmp is correct?
Yes i am, this is the Serverpath to the temp-folder, set in tne ACP -> vBulletin -> Serversettings and optim.

Quote:
Originally Posted by Morgan View Post
When I go to http://www.your-domain.de/forum/tmp/ I get a 404 not found message. Perhaps you need to use /var/www/web27/html/tmp instead and set the directory permissions so that http://www.your-domain.de/tmp/ does not generate a 403 forbidden message.
My domain links to -> "forum", so that the domainpath is -> http://www.your-domain.de//tmp/
When i upload an avatar or an attachment to the forum -> it works perfectly,
so i think, this settings must be ok!


But whats about the settings @ the gal (ACP)
There i have to set the serverpath and the URL to header images.
The Server path to images is -> /var/www/web27/html/forum/geek/ gal /images
and path of URL to header images is -> geek/ gal /images/

Where does GAL upload the images first (before moving)?
TMP or geek/ gal /images/1


kr Chris
__________________
sorry for my bad english ... my german is much better
Reply With Quote
  #8  
Old 03-12-2008, 12:14 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Uploads go to your server's /tmp and then to your safe mode temp directory and then get moved to the /geek/ gal /images directory or whatever directory you have set in the GAL ACP settings. When GAL created the /1 directory in the /geek/ gal /images directory, it tried to set 777 permissions on the /geek/ gal /images/1 directory. Do you see 777 permissions on the /geek/ gal /images/1 directory?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #9  
Old 03-13-2008, 12:44 AM
za4a tuner za4a tuner is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder 
Default

Yes, the Folders -> images + 1 + 4 <- have 777 permission!

I deleted the Folder "1" and get the following error:
Quote:
1. Cannot open server path for images.
after that i created the folders again, chmod is 777 -> and tried another upload =>
Quote:
1. Got some freaky error while moving file.
__________________
sorry for my bad english ... my german is much better
Reply With Quote
  #10  
Old 03-13-2008, 02:45 AM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Try setting 755 directory permissions on /tmp so that http://www.your-domain.de/tmp/ does not generate a 403 forbidden message.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can not upload header image stckhlm Geek Article and Review System 7 10-23-2008 07:38 PM
Limit file upload size (Thumbnail to original image upload) -RL- Geek Article and Review System 1 03-24-2008 06:25 PM
GAL Installed Failed calvis Geek Auto-Linker 3 03-12-2008 11:53 AM
Image upload issue autopia Geek Article and Review System 28 12-23-2006 08:41 PM
Error on IMAGE UPLOAD nymyth Geek Article and Review System 2 10-25-2006 10:02 PM


All times are GMT. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.