The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Gazette

Geek Gazette GAZ is a community newsletter management system.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2009, 07:28 AM
BuckGB BuckGB is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Geek Gazette License Holder 
Default Text Colors and Introduction Timestamp

I just sent out my first newsletter, but for whatever reason the text links are using the default blue/purple colors rather than what I have in my CSS. The newsletter looks fine when previewed, but the text link colors don't carry over to the actual HTML email. Any idea how I can avoid this issue in the future?

Also, you'll notice my newsletter introduction has a timestamp of 12-31-1969 rather than the current date. How can I ensure that the correct time is used in the next newsletter I send out?

Thanks for the help!
Reply With Quote
  #2  
Old 01-29-2009, 05:09 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Look at the HTML source for the email and see if the CSS for the links is there or has been stripped out or overridden by the email reader. For the date, what modules/setup are you using for the 'Newsletter Introduction' section?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #3  
Old 01-29-2009, 05:14 PM
BuckGB BuckGB is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Geek Gazette License Holder 
Default

I'm using the Info Block with "Use Issue Text" set to Yes. It looks like all of the necessary CSS elements are there when I look at the newsletter's source HTML. I can forward you the emailed version, if that helps.
Reply With Quote
  #4  
Old 01-29-2009, 05:40 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Go to the ACP -> GAZ -> Issues -> click the issue with the bad date -> set Refresh Layout to yes -> click the Save button and then do a preview. Is the date correct? For the CSS in the email, I'll need to see the HTML source. View the HTML source, copy-paste, and save to a text file, and then email the text file to the address in the PM sent to you. Do not forward the email to me; I need to see the HTML source.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #5  
Old 01-29-2009, 08:35 PM
BuckGB BuckGB is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Geek Gazette License Holder 
Default

Even after refreshing the layout, the date is wrong in the preview. The source has been emailed to you.
Reply With Quote
  #6  
Old 02-02-2009, 01:38 AM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

The links appear tan, and when hovered over appear yellow, in the text file you sent. What do you see when you save the text file you sent to your local machine, to a file named newslettersource.html and view it with your browser?

For the date, what do you get when you run this query:
Code:
# add your vB table prefix to the gaz_data table name if you use a prefix
SELECT postdate, displaydate, frequency FROM gaz_data WHERE id = 9;
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #7  
Old 02-02-2009, 06:44 PM
BuckGB BuckGB is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Geek Gazette License Holder 
Default

The CSS works when I save the text to an HTML file and view it locally. However, it isn't working when viewed in Outlook or any other email client that I have access to. After sending out the newsletter, I received a lot of replies from people claiming that they could barely see the blue links on a dark background, so it's obviously an issue for some (if not most or all) of the recipients.

Running that SQL query returns zeroes and a frequency of 1233032400.
Reply With Quote
  #8  
Old 02-05-2009, 05:33 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

It could be the email reader that overrides the CSS you are applying to the links. What happens if you look at the email using a different email reader?

For the date, what frequency are you using? With that the date can be set via a query: TIMENOW - frequency = 1233032400.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #9  
Old 02-05-2009, 08:09 PM
BuckGB BuckGB is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Geek Gazette License Holder 
Default

The only email clients I've tried are Outlook 2007 and a couple of web-based ones (such as mail2web). The CSS does not work in anything I've tried so far. Do you have any recommendations for another client I can check it in? If it doesn't work in Outlook, though, that's a big problem.

I turned off auto-generation of issues so I could manually send them out. With that said, the frequency is set to "Yearly", even though it's not active.
Reply With Quote
  #10  
Old 02-10-2009, 04:14 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Try using the 'email to friend' option on the main newsletter.php page and send me a copy to the email address in that PM and I can see how it looks in my email reader. For the date, try running the following query:
Code:
# add your vB table prefix to the gaz_data table name if you use a prefix
UPDATE gaz_data SET postdate = 1233032400, displaydate = 1233032400 WHERE id = 9;
Afterward go to the ACP -> GAZ -> Issues -> click the issue with the bad date -> set Refresh Layout to yes -> click the Save button and then do a preview. Is the date correct?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Change review ratings colors/style? Kreativmind Geek Article and Review System 1 05-23-2008 04:05 AM
How do I wrap text around the user info box, and change the alignment of the text? ziggy Geek Article and Review System 1 03-12-2008 12:30 PM
GAL links - custom colors? pixie Geek Auto-Linker 6 04-06-2007 08:43 AM
A short introduction to swish Wildthinks Reviews 1 02-02-2007 12:59 PM
How to change 'Introduction' JohnBee Geek Article and Review System 11 01-09-2007 06:52 PM


All times are GMT. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.