The vB Geek

Go Back   The vB Geek > vB Geek Products > Geek Auto-Linker

Geek Auto-Linker GAL automatically links keywords that users type in posts to advertising hover pop-ups.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2008, 04:54 PM
gldtn gldtn is offline
Senior Member
 
Join Date: Oct 2005
Location: Massachusetts, USA
Posts: 122
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default Autolink PHP

Hello morgan,

The autolink.php which should reside inside the forum dir gives us an 404 error if you have the forum in a separate forlder other than your main public_html/ folder, because it's trying to read as it was there, this seems to be hard coded in GAL .

So to make sure you understand;

I have my vBulletin in a folder /owner/public_html/forum/ and have placed autolink.php iside that folder. Now GAL is trying to read it as if it was in /owner/public_html/, maybe there should be a setting so the user can define forum directory under admincp?

Thanks!
__________________
http://www.braziltourism.org/
Reply With Quote
  #2  
Old 01-21-2008, 05:01 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

The autolink.php file should go into the directory matching with this:
Code:
$vbulletin->options['bburl'] . "/autolink.php ...
The vB bburl setting can be found under vB Options -> Site Name / URL / Contact Details -> Forum URL. Is your vB bburl setting to someplace else, or am I misunderstanding?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #3  
Old 01-21-2008, 05:58 PM
gldtn gldtn is offline
Senior Member
 
Join Date: Oct 2005
Location: Massachusetts, USA
Posts: 122
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

My Forum URL is correct(http://www.domain.org/forum).. seems to be reading the Homepage URL instead :/
__________________
http://www.braziltourism.org/
Reply With Quote
  #4  
Old 01-21-2008, 06:06 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Any htaccess redirection going on?
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #5  
Old 01-21-2008, 07:38 PM
cellarius's Avatar
cellarius cellarius is offline
Junior Member
 
Join Date: Dec 2005
Posts: 20
Geek Auto-Linker Pro License Holder 
Default

As you already now , I have the same problem. Running vbseo, but if vbseo is deactivatet, the problem stays the same. I have the exact same setting as gldtn, and my settings in vB are correct. There are no rewrite rules that could cause this as far as I can see.
Reply With Quote
  #6  
Old 01-21-2008, 07:59 PM
cellarius's Avatar
cellarius cellarius is offline
Junior Member
 
Join Date: Dec 2005
Posts: 20
Geek Auto-Linker Pro License Holder 
Default

First help:

Copy autolink.php to your site root. In autolink.php add right at the beginning, right after <?php

Code:
chdir($_SERVER['DOCUMENT_ROOT'].'/forum');
This will resolve the 404 issue for the moment. But beware: as soon as morgan fixes that bug, this line will probably break the autolink.php

Hope to help,
cellarius

Last edited by cellarius; 01-22-2008 at 05:33 AM..
Reply With Quote
  #7  
Old 01-21-2008, 08:26 PM
gldtn gldtn is offline
Senior Member
 
Join Date: Oct 2005
Location: Massachusetts, USA
Posts: 122
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

Morgan,

subdomain redirection only.. but even without the subsdomains it still does it.

cellarius,

Let me give it a try.. thanks!
__________________
http://www.braziltourism.org/
Reply With Quote
  #8  
Old 01-21-2008, 08:26 PM
Morgan's Avatar
Morgan Morgan is offline
Administrator
 
Join Date: Jul 2006
Posts: 2,255
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Thanks, but no need to do as in post six. Instead grab the GAL package again and FTP three files:
  • /geek/gal/includes/gal_class_core.php
  • /geek/gal/includes/gal_class_vb_db.php
  • /geek/gal/includes/gal_class_vb_db_dictionary.php
This should take care of the incorrect link as well as deal with the keywords where there is no content.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #9  
Old 01-21-2008, 09:02 PM
gldtn gldtn is offline
Senior Member
 
Join Date: Oct 2005
Location: Massachusetts, USA
Posts: 122
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

That did the trick morgan..

Thanks a lot!
__________________
http://www.braziltourism.org/
Reply With Quote
  #10  
Old 01-22-2008, 05:36 AM
cellarius's Avatar
cellarius cellarius is offline
Junior Member
 
Join Date: Dec 2005
Posts: 20
Geek Auto-Linker Pro License Holder 
Default

Quote:
Originally Posted by gldtn View Post
That did the trick morgan..

Thanks a lot!
Indeed - that was quick response, thank you!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
autolink.php question najaru Geek Auto-Linker 2 10-09-2009 06:40 PM
Can links point to "real URL" as opposed to .../autolink.php?id=1... JustaQuestion Geek Auto-Linker 1 09-28-2009 02:52 PM
Glossary term linking to autolink.php ? abrecher Geek Auto-Linker 7 06-15-2009 09:33 PM
Modifying forumview.php and showthread.php for GARS only? Lars-Christian Geek Article and Review System 9 04-11-2007 06:20 PM
Changing from index.php to forum.php? Michael Lizard Lounge 2 10-04-2005 03:27 PM


All times are GMT. The time now is 01:22 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.