View Single Post
  #1  
Old 03-26-2007, 06:04 PM
Milad Milad is offline
Member
 
Join Date: Nov 2005
Posts: 58
Geek Article and Review System License Holder Geek Gazette License Holder 
Default GAZ 1.0.0 beta 1 feedback and suggestions from Milad

Installation process:
- As of vB 3.6 you can add the cron job in the XML product file, I didn't like the fact that I had to setup a cron job manually while that can be done via XML file.

readme.html file:
correct the path: http://www.yoursite.com/forums/geek/..._send_cron.php to http://www.yoursite.com/forums/geek/...n/gaz_send.php


Settings:
- I found my personal email in Reply address setting, and this must be the default one of the forum $vbulletin->options['webmasteremail']
- Style and user information (Style, Userid and User Name): Here it's better to use the own setting for each user, and it's better to send the newsletter from the default email $vbulletin->options['webmasteremail'] not from the admin membership.

Newsletters:
- It's better to determine the scheduled time for each newsletter while adding or editing it not via the cron job which have to run to decide if it's the time to generate an issue or not. (I figured out later, this can be set in generators section)
- timing could be daily, weekly, biweekly and monthly .. etc.

Issues:
- Management here is good.

Generator:
- Management here is good.

Found errors:
- In Generators section, I chosen Preview last HTML issue, then new window popped up with this url http://www.syrianmeds.net/forum/.php?id=1&prev=1
- Also the link for Plain Text preview is http://www.syrianmeds.net/forum/?settings[scriptname].php?id=1&txt=1&prev=1
- The previous problems disappeared in newly generated issues, I think it's default data problem.
- In modules section, I receive this warning: Warning: Missing argument 5 for run_mod() in /geek/ gaz /includes/gaz_class_core.php on line 226
- In Plain Text preview, there are HTML code.
- In sending section for an issue I had this error Warning: Missing argument 1 for gaz_class_cron() in /geek/ gaz /includes/gaz_class_cron.php on line 22
- While you add a module to module set, if you set an order, it won't be set, you have to right it in order field and save again.

Sent HTML issue:
- It must have the HTML direction is wrong, it's ltr while my forum is rtl
- I choose not to show replies and views but their fields are still exist as empty fields.
- some parts don't obey right-to-left standards.

Notes:
- templates have to be grouped in the admincp
Reply With Quote