The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   /geek/gars/images VS /geek/gars/images/types (http://www.thevbgeek.com/showthread.php?t=953)

Stachel 01-21-2006 02:01 PM

/geek/gars/images VS /geek/gars/images/types
 
/geek/gars/images VS /geek/gars/images/types

What type of images should be in each directory?


I can't get my header image to appear, no matter how I change the setting in ADMINCP --> GARS --> Header images

When I look at the article display and see the dreaded Red X:

Properties of the Red X of the image next to Article Title, Author's Name:
http:// .com/geek/gars/images/redrose.jpg

Where I need it to be pulling from:
http:// .com/cforums/geek/gars/images/redrose.jpg


My settings:

Absolute path
/home/sandbox/public_html/cforums/geek/gars/images

Relative path
./cforums/geek/gars/images

(relative to what ??)


?? :eek:

Rich 01-22-2006 01:10 PM

Hello,

I think it is your relative path that is causing the error.

This is what you should have (I think):

Absolute:

/home/vbexpose/public_html/cforums/geek/gars/images


Relative:

./geek/gars/images

------------------------------------------------------------------

The relative path already knows that the directory is in the "cforums" folder. Give that a try.

Stachel 01-22-2006 01:12 PM

I'll try it - thanks!

Rich 01-22-2006 01:29 PM

Hello,

Make sure you post back letting us know if that worked. others may be having the same issue.

Stachel 01-22-2006 01:56 PM

Nope - didn't work.

The Red-X images still have the properties of:

http:// .com/geek/gars/images/redrose.jpg

when they should be

http:// .com/cforums/geek/gars/images/redrose.jpg



Is there another vBulletin setting somewhere causing a conflict?

Santai 01-22-2006 02:41 PM

Quote:

Originally Posted by Stachel
/geek/gars/images VS /geek/gars/images/types

http:// .com/geek/gars/images/redrose.jpg

Where I need it to be pulling from:
http:// .com/cforums/geek/gars/images/redrose.jpg
./cforums/geek/gars/images

(relative to what ??)


?? :eek:

relative to the dir your forums are in .

just started with this also ..

url is the web path .
if you use a " / " it should be " /cforums/geek/gars/images "
if you notice your output its missing the "cforums" but starts at geek, just what you put into the block .

i use " /forum/geek/gars/images " so it starts from the root folder .

( when working with the banners found this works and not the realtive path )
can see the banners in the admin-cp and the site even if it changes into another dir .


hope this works for you .

Rich 01-23-2006 12:23 AM

Hello,

I have my GARS installed in my "forum" directory. This is how I have my "settings" and all of my images display:

Absolute path to images:

/home/mysite/public_html/forum/geek/gars/images - Folder is chmod 777

Safemode upload on? - no (you might need yes?)

URL to your images folder can be relative:

./geek/gars/images

Lizard King 01-23-2006 12:49 AM

The problem you have is i think about your vBulletin settings. Check your site name and description settings. It adds .com before your folder thats why you are having this problem.

Stachel 01-23-2006 08:14 AM

I slept on it, tried all things above again, and those images above are still Red X's and being pulled from the wrong place
(with "cforums" missing from the URL of the image properties.)


Lizard King,
my Forum URL of this test instance is:

http:// [ip address] /cforums

Could the fact that I'm using a numerical IP address instead of a domain name affect it?

Since this is a test instance, my real domain name is taken (in use) by my live site. So I just use the IP address for the test instance.

Appreciate your brain cells noodling on this!

Stachel

Stachel 01-23-2006 08:28 AM

OK, maybe another clue:

The other article header images have the property:


http://1.2.3.4/types/1/default.jpg

where 1.2.3.4 is the numerical IP address of my test instance

What is pointing the header image reference to /types/1

What happens in that /types/... directory?

The article author is administrator, and "1" could be the UserID # .

The actual location of my types directory is:
/home/sandbox/public_html/cforums/geek/gars/images/types

The Red X's are because they are pointed to:
http://1.2.3.4/types/1/default.jpg

when they should be pointed to:
http:// ... /cforums/geek/gars/images/types/1/default.jpg


I hate Red X's !!!

Stachel


All times are GMT. The time now is 06:16 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.