The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Announcements (http://www.thevbgeek.com/forumdisplay.php?f=2)
-   -   GAL for vB4 has been released (http://www.thevbgeek.com/showthread.php?t=5630)

Morgan 05-22-2010 04:23 AM

GAL for vB4 has been released
 
GAL for vB4 has been released. Go to http://www.thevbgeek.com/glic.php to download the version available to you. If you wish to renew, go to http://www.thevbgeek.com/geekmart.php to obtain the latest version.

No information is yet available on the other geek scripts. When information is available, it will be announced. Certain geek scripts might not be updated for vB4. Support will resume after final determinations of all the geek scripts have been made.

To upgrade GAL for vB4, do the following:
  • Revert all customized GAL templates via the ACP, if changed from their originals. Failure to do so means GAL will not work correctly.
  • Copy the files included with the GAL for vB4 package into their corresponding folders on your server, overwriting existing files.
  • Import the product-gal-vb4.xml file via the ACP (AdminCP -> Plugins & Products -> Manage Products -> Add/Import Product). Do NOT uninstall, do allow overwrite.
  • Make sure to CHMOD the /geek/gal/images directory so that it has 777 permissions so that you are able to upload images.
  • Give yourself access: ACP -> Usergroups -> Administrator Permissions -> Edit Permissions -> Can Administer GAL -> Yes.
  • Refresh your AdminCP (e.g., Ctrl+F5).
  • Note: This step is no longer necessary for the vB4 version of GAL. For the vB4 version of GAL, the following CSS can be found in the gal_auto_link.css template via the AdminCP.

    If using vB3, then add the following CSS declarations to your vB AdminCP style CSS settings (Styles & Templates -> Stye Manager -> Main CSS -> Scroll to the bottom of the page -> Add the following in the lower Additional CSS Definitions box):
    Code:

          /* GAL Defns */
          a.gal:link
          {
                  text-decoration: none;
                  border-bottom: 1px dotted #016798;
                  color: #016798;
                  padding: 0 0 0 12px;
                  background: url(images/misc/exlinkon.gif) no-repeat 0;
          }
          a.gal:visited
          {
                  text-decoration: none;
                  border-bottom: 1px dotted #016798;
                  color: #016798;
                  padding: 0 0 0 12px;
                  background: url(images/misc/exlinkon.gif) no-repeat 0;
          }
          a.gal:hover, a.gal:active
          {
                  text-decoration: underline;
                  border-bottom: 0px dotted #F8BF24;
                  color: #016798;
                  padding: 0 0 0 12px;
                  background: url(images/misc/exlink.gif) no-repeat 0;
          }

  • Any "word" character (\w), apostrophe ('), and dash (-) are allowed in keywords, now including ampersand (&) and period (.) but as vB typically &s the & character, take this into account when entering keywords. And like before Ajax'd items need a refresh to see the auto-links.
  • The "follow" option for GAL popups has been reworked as best as possible to try and make it vB4 compatible, but if you experience problems with "follow" that cannot be rectified with the X/Y offset options via the ACP, then you will need to choose either "hover" or "close" instead.
  • GALs in vB4 are not bounded by the screen so they might appear off screen, but there are anchor, X offset, and Y offset AdminCP options to have the pop-up appear in different places on the screen and a gal.js file edit shown here to try and bound on the left and right sides.

Morgan 05-22-2010 07:06 PM

There is a JavaScript error in GAL for those of you who do not have GAB installed. To be rid of this error, do the following.

If you haven't yet installed GAL for vB4 then discard the GAL for vB4 package you may have downloaded and go and downloaded it again at http://www.thevbgeek.com/glic.php

If you have installed GAL for vB4 then discard the GAL for vB4 package you downloaded and go and download it again at http://www.thevbgeek.com/glic.php and then re-import the product-gal-vb4.xml file via the ACP (do not uninstall, do allow overwrite) and then go to a forum page with GALs on it and hard refresh (e.g., hit Ctrl-F5) that page or clear your browsers cache. Any of your members who report a JavaScript error after that point will need to either hard refresh or clear browser cache to be rid of any cached version of the page. As you have already upgraded GAL for vB4, you only need to re-import the product-gal-vb4.xml file to apply the fix.


All times are GMT. The time now is 06:45 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.