The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   vBulletin 3.7.2 PL1 Compatibility (http://www.thevbgeek.com/showthread.php?t=4481)

whsky2222 07-23-2008 06:57 AM

vBulletin 3.7.2 PL1 Compatibility
 
Hi,

After I installed GARS in my host and logged out from the ACP I got the following error message;


Warning: require_once([path]/geek/gars/includes/gars_ignition.php) [function.require-once]: failed to open stream: No such file or directory in [path]/global.php(365) : eval()'d code on line 1

Fatal error: require_once() [function.require]: Failed opening required '/home/turkeyho/public_html/geek/gars/includes/gars_ignition.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/turkeyho/public_html/global.php(365) : eval()'d code on line 1


How can solve this problem as I cannot view my website anymore.

Thanks,

Regards,

Morgan 07-23-2008 01:41 PM

Check to see where you FTPed the GARS files. For example, the gars_ignition.php file should be located inside the /forum/geek/gars/includes directory where the /forum directory is your vB forum directory, the same directory holding the vB showthread.php file.

whsky2222 07-26-2008 07:40 PM

Still not working...
 
Hi,

I checked the folders which came out of the zipped file "upload". There was "forums" folder and I uploaded it all including the subfolders. I did not moved any file out of their original folders.

Here is how I uploaded and installed GARS.

I uploaded the folder called "forums" found in the upload folder under the /public_html folder on the server where all other vBulletin files were.

Then through the product manager I uploaded and installed product-gars.xml file.

After I checked out my ACP I got the error message that I sent in my previous post. I did all the steps described in the vbgeek wiki.

Can you please give more information to sort this out.

Many thanks,

Morgan 07-26-2008 10:44 PM

A "no such file or directory" error is pretty specific. The "forums" folder is your forum's folder, not a subfolder, i.e., the files are not in the correct location.
Quote:

For example, the gars_ignition.php file should be located inside the /forum/geek/gars/includes directory where the /forum directory is your vB forum directory, the same directory holding the vB showthread.php file.
  • /forum
    • /geek
      • /gars
        • /includes
          • gars_ignition.php
    • showthread.php

whsky2222 07-31-2008 05:22 PM

Help needed
 
Hi,

I do not have a seperate folder as "forums" to put the vBulletin files in. I put v Bulletin files directly under the root folder on my host which is called "public_html".

So can you please tell me where to put the files & folders in the upload folder that came out of the zipped file.

For instance where should I put the admincp folder (found in the upload folder of GARS) in the root folder as there is already a folder includes the vBulletin admincp files.

And where should I upload the rest of the folders under the "public_html" folder; geek, images, includes and marked.php, reviewrate.php?

Many thanks,

Regards,

pipin 07-31-2008 06:14 PM

You have to put all files in the forums root.

so marked.php and reviewrate.php go straight to this public_html.

the files in the admincp go to the same folder admincp of vbulletin. the same for images and includes.

the geek folder goes to the root of your forum too.

whsky2222 07-31-2008 11:54 PM

At last it worked!
 
Quote:

Originally Posted by pipin (Post 25619)
You have to put all files in the forums root.

so marked.php and reviewrate.php go straight to this public_html.

the files in the admincp go to the same folder admincp of vbulletin. the same for images and includes.

the geek folder goes to the root of your forum too.

Hi,

Appreciate your help. It worked.

Thanks again,

Regards,


All times are GMT. The time now is 12:07 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.