The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Gazette (http://www.thevbgeek.com/forumdisplay.php?f=56)
-   -   Gaz Subscription Problem (http://www.thevbgeek.com/showthread.php?t=4477)

KenDude 07-22-2008 06:44 AM

Gaz Subscription Problem
 
Morgan,

After sending out my newsletter tonight I noticed that it seems that NEW members when they register have the receive newsletter flag in their profile set to NO by default. I would like to set that to YES by default, but did not see how to do so. Can you help?

Additionally, I now have about 800-900 members whose flags I'd like to turn to YES from No. When I go into the subscriptions and try to sort by members with their subscription flag to NO who have joined the site since May 1, 2008, I am getting ANY member with the flag to No, it is as if it is ignoring the combination of criteria that I am trying to set.

Can you help me get these members (and only these members) set to YES please?

Thanks!

KenDude 07-22-2008 06:56 AM

BTW in Newsletters for the only newsletter I have (called monthly newsletter) the setting for:

Default to subscription?
Users will be subscribed to newsletter by default

Is set to YES. Yet, it is NOT defaulting to subscribing members.

Morgan, I think you still have access to my admincp if you'd like to take a look.

Morgan 07-23-2008 02:37 AM

Grab the GAZ package again, FTP the PHP files to the server, overwriting the old ones, re-import the product-gaz.xml file via the ACP (do not uninstall, do not revert templates for this update, do allow overwrite).

KenDude 07-24-2008 05:32 AM

Morgan,

I did as you requested, now I'll check new members and see if they get subscribed by default as they should be. Is there any way to quickly fix the new members in the last 2-3 months who have their subscription set to NO without affecting members prior to that time who might have chosen not to subscrbe? In other words turn the subscription ON for members new to the site since xx/xx/xxxx date? When i try searching in this fashion in the subscriptions section of admincp it doesn't like that combined search, if I tell it to search for new members since say May 1, 2008 who are set to NO, it returns ALL members set to No, at least it did the other day, I'll go check that again after this upgrade. What all was fixed in 2.02?

KenDude 07-24-2008 05:35 AM

Oh and is there also any way I can send these people new to my website since May 1, 2008 the latest newsletter since they didn't get it when I just sent it out???

KenDude 07-24-2008 05:38 AM

Ok the searching under subscriptions seems to work correctly now so I was able to identify those members who were not auto-subscribed and subscribe them, now I just have to figure out how to send them the newsletter.. :)

Morgan 07-24-2008 09:24 PM

The subscription search will let you find those users between the cracks so to speak, but nothing to send just to them unless you do it manually.

KenDude 07-24-2008 09:31 PM

How do you manually send 1 person a newsletter btw? Is there any way to manually send to a single group? So if I dumped all those members into a group could I get them all by manually sending to only members of that group?

Morgan 07-24-2008 10:18 PM

Individual emails can be sent via the newsletter.php page using the email to a friend option, assuming you have permission. No send to a certain group exists, but you might be better off just doing a copy-paste of the email addresses found via the subscription search and forwarding a BCC newsletter email to the manually created list of emails.

KenDude 07-28-2008 05:49 AM

Thanks! Sounds like a future feature request then! :)


All times are GMT. The time now is 05:58 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.