The vB Geek

The vB Geek (
-   Geek Article and Review System (
-   -   GARS not shown in AdminCP until Admin-User is Superadmin in config.php (

Muah 07-07-2008 08:41 AM

GARS not shown in AdminCP until Admin-User is Superadmin in config.php

i have installed GARS 2.19 on VB 3.6.8. The second Admin-User got all Admin-Rights, but he didnt see GARS in AdminCP NavFrame. Copied the Forum (files and DB) for testing update to VB 3.7.2. Same fault.

I read some threads here, but no one could solve the Problem (re-install Product, re-save Admin-Settings for user and so on).


Morgan 07-07-2008 07:32 PM

Check that the ACP -> Usergroups -> Administrator Permissions -> Edit Permissions -> Can Administer GARS is set to yes, and have the other admin refresh the ACP (e.g., hit Ctrl+F5) afterwards.

cluanar 08-08-2008 09:15 PM

i have the same problem and they have the permission set

Morgan 08-10-2008 02:55 AM

Sorry, it's a bug. I'll make a fix and post when it is available.

mac27 08-12-2008 01:57 AM

Yes have the same issue on another forum I admin on right now also. Looking forward to a fix for this.

Morgan 08-12-2008 01:21 PM

The latest GARS package has been updated with the fix, so you can grab the latest GARS package again and reimport the product-gars.xml file via the ACP (do not uninstall, do allow overwrite) but remember that your custom templates and phrases for GARS add-ons (i.e. the link directory and/or the release add-on) will get wiped out. After reimporting the XML file, you will need to use the GARS importer to reimport the add-ons (making sure you choose the option to import phrases and templates only).

Alternatively, you can make the required change (without reimporting the product-gars.xml file) by going to the ACP -> Plugins & Products -> Plugin Manager -> edit the 'GARS - Admin Index Navigation' plugin as follows and then save the changes:

Product: GARS
Hook Location: can_administer
Title: GARS - Admin Can Administer
Execution Order: 5
Plugin PHP Code:

if (in_array('canadmingars', $do))
        $garsadminperms = $vbulletin->db->query_first("SELECT garsadminperms
                FROM " . TABLE_PREFIX . "administrator
                WHERE userid = " . intval($vbulletin->userinfo['userid']) . "
        if ($garsadminperms['garsadminperms'])
                $return_value = true;

Plugin is Active: Yes

cluanar 08-13-2008 05:06 PM

thank you, worked like a charm

mac27 08-14-2008 04:17 AM

Yes thank you for the fix. Worked great.

ThailandTopper 08-20-2010 08:01 AM


I'm running vB 3.8.4 and am having this exact same problem. I've just purchased this today so I'm relatively sure I've got the latest updates.

I've tried everything I know of and tried everything in this thread, even to doing the above mod manually to the can-administer hook.

If you have any other hints, please let me know.

ThailandTopper 08-20-2010 08:28 AM

I simply can't make myself an administrator of GARS. I've tried everything from deleting my permissions from the config.php file to adding them back in and everything in between. I've double and triple checked the files and their location.

All times are GMT. The time now is 01:15 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.