The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Announcements (http://www.thevbgeek.com/forumdisplay.php?f=2)
-   -   New GAL version is here! (http://www.thevbgeek.com/showthread.php?t=3834)

Morgan 01-21-2008 12:26 AM

New GAL version is here!
 
Well folks, the new version of GAL is here. No worse the wear on this end, save those all-nighters. :p

Features

Auto-link keywords. Change keyword category, dictionary, status, and more from one AdminCP page. Filter by category. Choose templates and regular expressions to use. Lots of permissions. Statistics for tracking impressions and clickthroughs. Works with GARS. More.

Click here to see how it looks in posts. Click here to see the front-end script.

Issues

Non-post items may not auto-link. Ajax quick replies may not auto-link. Non-post auto-links experimental and done on the fly. For posts, you can Rebuild Post Cache but it is intensive. Do not go overboard. Lack of documentation. Not 100% phrased.

Installation
  • Copy the files included with this package into the corresponding directories on your server. Overwrite existing GAL files. Make sure that the contents in /forums/images gets copied into each of your style's images directory.
  • Upload the product-gal.xml file via the vB AdminCP product manager. This will install the required database tables, templates, plugins, phrases, etcetera.
  • Make sure that the /geek/gal/images directory is CHMOD to 0777 for uploading images.
  • Give your AdminCP a hard refresh (e.g., Ctrl-F5) if you do not see the side menu after installation. Go to the vB AdminCP -> Geek Auto-Linker -> Settings and fill in the options.
  • Click through all the GAL AdminCP pages to familiarize yourself with the options and settings. Note that dictionaries have permissions, categories have permissions, and there are more permissions to be found by following the Permissions link in the side menu.
  • Add the following CSS declarations to your vB AdminCP style CSS settings (Styles & Templates -> Stye Manager -> Main CSS -> Scroll to the bottom of the page -> Add the following in the lower Additional CSS Definitions box):
    Code:

    /* GAL Defns */
    a.gal:link
    {
            text-decoration: none;
            border-bottom: 1px dotted #016798;
            color: #016798;
            padding: 0 0 0 12px;
            background: url(images/misc/exlinkon.gif) no-repeat 0;
    }
    a.gal:visited
    {
            text-decoration: none;
            border-bottom: 1px dotted #016798;
            color: #016798;
            padding: 0 0 0 12px;
            background: url(images/misc/exlinkon.gif) no-repeat 0;
    }
    a.gal:hover, a.gal:active
    {
            text-decoration: underline;
            border-bottom: 0px dotted #F8BF24;
            color: #016798;
            padding: 0 0 0 12px;
            background: url(images/misc/exlink.gif) no-repeat 0;
    }

  • Note that any "word" character (\w), apostrophe ('), and dash (-) are allowed in keywords.
  • Do not allow just anyone to use HTML! You do not want someone wreaking unnecessary havoc.
  • Choose keywords wisely. Make meaningful selections. Do not auto-link common words. It is undue overhead.
  • If you wish to use GARS and GAL together, you will need to grab the GARS package and FTP the /geek/gars/includes/gars_class_edit.php file.

ang2el 01-21-2008 01:48 AM

Thanks for this wonderful release, I am testing:D

Tigratrus 01-21-2008 02:02 AM

Double Super Yea! Heh... Gothic's gonna explode with joy. He's been waiting a looooong time for this.

Thanks Morgan!

James and Susan

KenDude 01-21-2008 02:16 AM

I saw a system similar to GAL on another web forum where the pop-up window had an RSS feed in it, is that something GAL can do?

calvis 01-21-2008 02:25 AM

Quote:

Issues

Non-post items may not auto-link. Ajax quick replies may not auto-link. Non-post auto-links experimental and done on the fly. For posts, you can Rebuild Post Cache but it is intensive. Do not go overboard. Lack of documentation. Not 100% phrased.
Those are some pretty serious issues. Most of my users use quick replies.

Morgan 01-21-2008 02:27 AM

See http://www.thevbgeek.com/showthread.php?t=2804 for more information about Ajax and auto-links.
Quote:

Originally Posted by The Geek (Post 16225)
... Please note that GAL will cache your quickpost posts - but will not show the results after the AJAX update. This is a limitation with the ajax display (you cant hook into it).


miyukichii 01-21-2008 02:42 AM

Looks nice ] I can't wait for GAB to be released *-* if i am not mistaken, GAB is to add advertising banners right ? Just like using vbadvanced, add extra blocks ? I hope it is easy to use.

calvis 01-21-2008 02:48 AM

OK, so it will show after the update...if that is the case then that is not a deal breaker.

Hornstar6969 01-21-2008 03:00 AM

Looks like only GAB auto linked, the other 2 didn't.

Morgan 01-21-2008 03:02 AM

They would have linked. Try it yourself. Make a quick reply, and then go to another page and then come back. Didn't want to clutter this thread with test posts:

GARS GAB GAL

Edit:

GARS GAB GAL
GARS GAL GAB
GAB GARS GAL
GAB GAL GARS
GAL GAB GARS
GAL GARS GAB

Edit2:

GARS bunny GAB bunny GAL
GARS bunny GAL bunny GAB
GAB bunny GARS bunny GAL
GAB bunny GAL bunny GARS
GAL bunny GAB bunny GARS
GAL bunny GARS bunny GAB

Edit3:

Well that just blows.

Edit 4:

Just goes to prove how freaking tired I am... I had GAL (the program) set to not auto-link GARS and GAL (the keywords) in this thread. I have now switched GAL (the program) to not auto-link this entire forum. GAL (the script) is running a-okay so far.

Hornstar6969 01-21-2008 03:11 AM

^^ yeah, still only GAB showing for your post lol refreshed a few times and still didnt work.

BTW with GAL 6. Is it using the new framework that The Geek was working at making for it originally? that he used in his AME mod?

WhatChaMissin 01-21-2008 03:32 AM

Congrats on your latest release. Its great to see this site alive again. Thanks for all your hard work Morgan.
________
LAUNCH BOX

Morgan 01-21-2008 03:45 AM

Ha ha ha ha, I had GAL (the script) set to not link GARS and GAL (the keywords) in this thread. That is all. So that means all is fine.

Hornstar6969 01-21-2008 04:02 AM

Okay cool, however have you now enabled it now?

Because I just noticed after refreshing several times, none of the above Auto links are now linking at all.

test:
GAB
GAR
GARS
GAL
lol
spider


Edit:

noticed your edit, okay cool.

Quote:

Edit 4:

Just goes to prove how freaking tired I am... I had GAL (the program) set to not auto-link GARS and GAL (the keywords) in this thread. I have now switched GAL (the program) to not auto-link this entire forum. GAL (the script) is running a-okay so far.

Morgan 01-21-2008 04:10 AM

Thanks, what I do is take the most recent version to which I have access and work from that. I cannot tell you if that is the most recent version that The Geek had but presumably a lot of the framework was in the GAL version from which I started. GAL was between states when I started working with the code, but so far so good. If you want to test the Ajax thing, do it here as I have turned off auto-linking in this forum. I don't want it to distract from the original post, but if you test in the other thread, you'll see it works as I previously stated. Silly me for forgetting what I had on/off but hey, I'm allowed. :o

tom 01-21-2008 04:33 AM

Quote:

For posts, you can Rebuild Post Cache but it is intensive.
Can you elaborate on this Morgan? Does this version insert bbcode in each post and therefore all posts need to be processed?

Morgan 01-21-2008 04:45 AM

If ever there is a hiccup and something that should be linking doesn't link, you can run Rebuild Post Cache to update the post cache, but you shouldn't find yourself needing to do that often. Not sure if it is a point of confusion, so just in case, I'll try to explain the Ajax thing. On full replies GAL can auto-link right as soon as you post, as that is a full page request, but with Ajax Quick Reply, it is a partial page request, so while GAL knows whether something needs to be auto-linked, the actual link doesn't show until the next time around. That is not something for which you should be running Rebuild Post Cache.

gothic 01-21-2008 06:53 AM

Quote:

Originally Posted by Tigratrus (Post 22477)
Double Super Yea! Heh... Gothic's gonna explode with joy. He's been waiting a looooong time for this.

Thanks Morgan!

James and Susan

Lol ... Yep, Christmas come early http://www.cornishserver.com/01.gif http://www.cornishserver.com/01.gif
Gonna test it locally for a little this morning, but really looking forward to installing it later on.
Many thanks.

gothic 01-21-2008 06:56 AM

Quote:

Originally Posted by Morgan (Post 22475)
[*] If you wish to use GARS and GAL together, you will need to grab the GARS package and FTP the /geek/gars/includes/gars_class_edit.php file.[/list]

Sorry for what is probably a silly question (just crawled out the bed, first litre of coffee still brewing :o )
What do you mean 'and FTP the /geek/gars... etc' erm, FTP to where/what/do what with it???

Lizard King 01-21-2008 09:31 AM

Is this version really going to work without any problems ? I donot want to renew a buggy product again. As i renewed and used Gal without any single update for a really long time.

Namaless 01-21-2008 03:56 PM

Good Release, one information before to get Licence: this script is compatible with vBulletin 3.7 Beta 3?

Thanks :)

Morgan 01-21-2008 05:48 PM

Quote:

Originally Posted by gothic (Post 22507)
Sorry for what is probably a silly question (just crawled out the bed, first litre of coffee still brewing :o )
What do you mean 'and FTP the /geek/gars... etc' erm, FTP to where/what/do what with it???

Mmm, coffee. If you want the GARS/GAL integration to work, you need to grab the GARS package and FTP the gars_class_edit.php file into the /geek/gars/includes directory.

Quote:

Originally Posted by Lizard King (Post 22510)
Is this version really going to work without any problems ? I donot want to renew a buggy product again. As i renewed and used Gal without any single update for a really long time.

The code base from which I started was 'worse' so to speak for GAL then GARS, as GAL was in a state of transition, but from my end, GAL 6 seems to be functioning a-okay. That is not to say there aren't any bugs, but I suppose the best way for you to tell whether you want to upgrade is to watch the forums for bug reports and support.

Quote:

Originally Posted by Namaless (Post 22519)
Good Release, one information before to get Licence: this script is compatible with vBulletin 3.7 Beta 3?

Thanks :)

Haven't heard of any problems related specifically to vB 3.7 yet. Should be fine and dandy.

KenDude 01-22-2008 06:36 AM

Quote:

Originally Posted by KenDude (Post 22479)
I saw a system similar to GAL on another web forum where the pop-up window had an RSS feed in it, is that something GAL can do?

Morgan,
Was this question answered? If so I missed the answer.

TIA!

Morgan 01-22-2008 06:40 AM

Yep, answered: http://www.thevbgeek.com/showthread....2478#post22478

Namaless 01-22-2008 05:20 PM

Thanks Morgan. Now propose to my Club this Product :)

Nitro 01-22-2008 07:05 PM

How easy does GAL 6 integrate into other vbulletin addon products including 3rd party addons ?

Morgan 01-22-2008 09:01 PM

It is meant for showthread and showpost, and while there is a setting to allow auto-links to appear on other pages based on THIS_SCRIPT, that feature works on the fly, affects the whole page, and is experimental.

Nitro 01-25-2008 10:55 PM

So its not like the past 4.x/lite versions then where you could include the gal functions file in other scripts if nesecary and run variables through the gal function for on the fly process by a fairly simple hacking of the addons code ?

Morgan 01-26-2008 09:01 PM

Sorry, there is too much for me to do to go back and see what GAL 4 did, but with GAL 6 you can do as described in post 27 for other pages. Perhaps whatever was done with GAL 4 might still work with GAL 6 but it is untested.

f4vn 02-26-2008 06:15 PM

I want to buy it but my payment is not successfull :( I don`t know why ?

Morgan 02-26-2008 11:58 PM

Quote:

Originally Posted by f4vn (Post 23305)
I want to buy it but my payment is not successfull :( I don`t know why ?

That is something you would need to email PayPal about, as I do not know the reason why PayPal doesn't like your payment.

.Joel 03-12-2008 11:25 AM

Hi Morgan,

Just a bit of a timeline question. We are currently using Gal on our forum for quite a while (nearly a year I believe). At this point we are preparing to launch a huge update to the website and are playing between the idea of using VB 3.6 series, or going with an RC1 of VB 3.7. How long after 3.7 goes RC do you believe this to work with 3.7? Just seems the timing is right to be preparing for the next gene pool of VB.

Regards,

.Joel

Morgan 03-12-2008 01:43 PM

IIRC haven't heard of any non-working issues with vB 3.7 so should work now.

.Joel 03-15-2008 02:05 PM

Hi Morgan,

Thank you for the reply. I have installed and found most of our custom modifications (in short made by us or designed explicitly for our purposes) have all worked a treat.... so far. Infact I was hedging my bets on needing to mod a few things, but so far all is good.

I'll try GAL tonight / tomorrow and report back with my findings, hopefully this successful trend continues.

On a side note, well done on maintaining this project. Hopefully you are getting back what you first envisioned when you took over the support and development role here. I for one am most appreciative of you doing this. Yes it is a one man show, and you will have people bitch, cry and moan at any given opportunity. Just ignore it, let it slide. We all knew what we were getting into here, there's nothing to hide, it's an open forum. Keep your head up and know that you are doing an excellent job.

Regards,

.Joel


All times are GMT. The time now is 12:29 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.