The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   GARS 2.1.6 Release discussion (http://www.thevbgeek.com/showthread.php?t=2995)

The Geek 03-24-2007 10:36 AM

GARS 2.1.6 Release discussion
 
GARS 2.1.6 is a maintenance release for the 2.1 branch to address open bugs. The primary fix is related to ratings in languages where the decimal place holder is a comma although other small bugs have also been fixed in the process.

To upgrade from a previous version:
  1. Download the latest package from the download section
  2. Unpack and upload the contents of the forums folder into your forums directory (overwriting existing files).
  3. Import the product-gars.xml file into your product manager (choosing the overwrite option)
  4. If you have any GARS add ons (i.e. the release or link directory) then you will need to re-import the add on xml files vie GARS add on importer. Please note that you should choose the option for 'phrases and templates only' when upgrading
  5. Browse to admincp->gars->tools and choose to rebuild custom field phrases
nJoy

jluerken 03-24-2007 07:58 PM

Hi Geek,

importing the product does not work. I do not get any update info when I try to import the product.

Can you assist?

Update: I think its imported now but the product still says v 2.1.5 instead of 2.1.6

The Geek 03-24-2007 08:14 PM

Yea, just noticed and am updating the entire package right now. Figure out what the problem was?

Quisaz Haderach 03-26-2007 08:05 AM

Hello,
How do I keep phrases for GARS when I do upgrade process?
Just select GARS Product and then Download phrases from the admincp language manager?
And after upgrading the Product just re-import that xml from language manager?

Quisaz Haderach 03-26-2007 08:24 AM

After re-importing the Link directory (no re-upload all files from ftp, only the xml from the gars package importer by selecting option for 'phrases and templates only')

This is the result:

Quote:

Terms

* An existing term set called Link Directory matches imported Link Directory. As such it won't be imported.

Cached terms

Built languages

Saved settings
it is all right?
Thanks for any Reply

P.S: I see the phrases for GAR that I have translated aren't lost, they are Ok.
Just because I haven't translated by the XML but from phrase by phrase selecting from the term link, they are inglobed in a full vBulletin language?

The Geek 03-26-2007 08:41 AM

Its always a good idea to export your translations before upgrading just in case. The message above is fine - it just means that it isnt importing a term set.

HTHs

Quisaz Haderach 03-26-2007 12:38 PM

That happen when I try to remove a Link:

Quote:

Database error in vBulletin 3.6.5:

Invalid SQL:
UPDATE vb_gars_rating_users set softdeleted=1 WHERE threadid=815;

MySQL Error : Unknown column 'softdeleted' in 'field list'
Error Number : 1054
Date : Monday, March 26th 2007 @ 01:36:33 PM
Script : http://www.lottosqueeze.org/postings...d&threadid=815
Referrer : http://www.lottosqueeze.org/postings.php?t=815&pollid=
IP Address : XXXXXX
Username : Quisaz Haderach
Classname : vb_database
How to I fix?

Quisaz Haderach 03-26-2007 01:30 PM

Sorry for that much post but it's needed, I see too after post a link, it showin all correctly but after a refresh or logout or exit (when I try to delete) and return on the link, it don't show the thub and the www icon, same error above when I try to delete a link, another small issue is the signature, it don't show in a link post (no t in a comment)

I think this is a bug for the new release (this 2.1.6), that problem come out too with articles, reviews, tutorials:

Quote:

Database error in vBulletin 3.6.5:

Invalid SQL:
UPDATE vb_gars_rating_users set softdeleted=1 WHERE threadid=797;

MySQL Error : Unknown column 'softdeleted' in 'field list'
Error Number : 1054
Date : Monday, March 26th 2007 @ 04:31:32 PM
Script : http://www.lottosqueeze.org/inlinemo...&threadids=797
Referrer : http://www.lottosqueeze.org/inlinemod.php?forumid=51
IP Address : xxxxxxxxx
Username : Quisaz Haderach
Classname : vb_database
and this now cause the problem on all the forum message without using gars type but as a normal VB forum! Please, it's urgent.. message is the same, help.

By disabling the product via "Product Manager" the deletion posts/threads works fine.

Another issue, I've removed all the new created forums and marked Articles, Reviews, when they are removed (deleted) some deleted Articles previous inside the deleted forums showing anyway in the module articles if I set an existing forum as Article forum or Review Forum, but the link does not exist.
Tried to delete all vbulletin cache and GARS cache, module cache, but nothing to do.

My fear is, hope that don't destroyed my forum database and lost all my forums post and users, settings, ecc..

The Geek 03-26-2007 04:58 PM

ok. Ill fix this and release an itermim update... IN the meantime, edit your gars_ratins_users table and add a new field called softdeleted type: tinyint

or hang on untill later tonight!

Quisaz Haderach 03-26-2007 05:38 PM

1 Attachment(s)
Ok, I prefer to wait your patch too
but I've modified by adding a field, there's the screenshot, please let me know if it's all good.

EDIT, adding text: Ok, now when I deleting the thread there's the message it shows
Quote:

Warning: Invalid argument supplied for foreach() in /geek/gars/includes/gars_admin_ratings.php on line 364
and thread deleted.


All times are GMT. The time now is 12:13 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.