The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   GARS and IE 7 (http://www.thevbgeek.com/showthread.php?t=2865)

waltercat 02-17-2007 03:40 PM

GARS and IE 7
 
Gars isn't really jiving with IE7 on a few levels. It looks superb in FF yet IE7 is having trouble containing the content for my forums with fixed widths.

Please see view these pages in IE7 and FF to see the difference:

http://www.prenatalyogacenter.com/fo...t=2061&garpg=4

Content area is pushing everything else out. Text in table of Contents and module is centered.

http://www.prenatalyogacenter.com/fo...t=2061&garpg=2

Same thing here. This seems to be happening because I have a table of contents and am breaking pages (which btw is an awesome feature).

I've narrowed it down to images. If I add an image with BBcode it mucks up the format in IE7.

I'm currently on GARS 2.0.0.

The Geek 02-18-2007 04:19 PM

I can only suspect an IE7 bug in rendering the inline image. You can try editing the GARS_pb template to remove the justify alignment to see if that helps

waltercat 02-19-2007 01:13 AM

Which part is the justify alignment section. Sorry, the pb template is a pretty confusing template for a novice like me. :D

The Geek 02-19-2007 04:34 PM

lol - just search for align="justify" and remove it :)

waltercat 02-20-2007 01:25 AM

Oh, I had already tried that and it didn't work. I thought there may have been another section. I still have the problem. It happens when I add images. Text by itself works fine.

The Geek 02-20-2007 09:05 AM

Try this: Edit GARS_pb and change:

style="padding: 0px 10px 0px 10px;"

to

style="padding: 0px 0px 0px 0px";

waltercat 02-23-2007 01:45 AM

No that doesn't work either.

The Geek 02-23-2007 08:24 AM

huh, I downloaded a local copy of the page in question and played around with it for a time - that did the trick for me. There are several IE7 rendering issues - one of them cenetered around child elements inheriting margins which I suspect may be the problem

waltercat 02-24-2007 03:35 PM

I guess I'll try to fiddle around with the style, since it is a child style that I am using for my forum. When I removed it from the parent made some changes to the site, so I need to figure out how to remove it from the parent and then make the changes I need.

Lizard King 02-25-2007 12:04 AM

You can remove the space by modifiying toc.php file.

Open public_html/forum/geek/gars/mods/display/toc.php search for <ul> and change it with <ul class='smallfont' style='list-style-position: inside;'>


All times are GMT. The time now is 11:42 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.