The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   GARS 2.0 RC4 Release Discussion (http://www.thevbgeek.com/showthread.php?t=1970)

The Geek 08-23-2006 08:59 PM

GARS 2.0 RC4 Release Discussion
 
HowdA All,

GARS 2.0 RC4 has been upload to the download areas for valid license holders. Please note this post contains important installation and upgrade information. Since this is a pre-release, there isn't a readme and you should only use on a test board.

I'm pretty sure this puppy is only needing phrases now. I have squashed all open bugs in the tracker and added a couple new features. The most important is the new package importer/exporter.
The package importer/exporter allows you to export a GARS configuration for someone else to import.
All users can import, but only users of vb3.6 can export right now.

Please note about importing:
  • The importer does a pretty good job trying to figure out what is and what isn't installed already so you don't end up with a butt load of duplicated stuff.
  • The importer gives pretty detailed information about what was done including direct links to new/existing items of importance. This allows you to quickly jump to a configuration page without losing your place :)
  • The importer does have some limitations:
    • It can not configure module settings. Therefore you usually need to edit your modules set (if it made one) and edit the modules settings - making sure you resave if it looks cool.
    • It can not upload header images. Therefore if the package creates a new type, you most likely will want to edit it and upload a header image.
There is also now an option to hide the header image upload/gallery box. Saying that, you will need to tweak your template accordingly.

I have uploaded 2 packages to get you started:To upgrade from RC3x, download the latest package and upload ALL files from the new RC4 package overwriting all old files (you do not actually have to upload the geek/gars/images folder or the geek/gars/cache folder).
Re-import the new product.xml file (overwriting existing installation).
Revert templates.

Please leave this thread open for the discussion of this release. All bugs should be posted in the bug tracker and all troubleshooting done in the troubleshooting forum.

24.08.2006

Updated package to RC4b to adress several issues with RC4 primarily centered around ratings. In fact, I have had to rewrite much of the ratings code base (needed it anyway).
I have also fixed a bug with the importer bringing in templates with php4.0
I fixed the mysterious invisible type that appeared out of nowhere.
I added support for quick replies using ajax. Now your ratings/templates appear as normal.
To update, you will need to upload the latest files (i.e. the package) over your previous ones.
You will also need to Re-import your product xml as there are some plug in changes.

25.08.2006

Updated package to RC4c to address issues with RC4b. Mainly centred around inability to save custom fields, etc...
Have further tweaked ratings a bit. There are so many differing configurations availible that its a real paid to test around all types.
I also enabled Ajax rating on vb3.6 (doesnt work on 3.5x). This caused a LOT of headaches. Had it working sweet until I cranked open IE6 and all hell broke loose. I had to retweak so ie would play nice. Sad thing is that I lost some of the functionality (your new values wont load back into selection box once you submit). Im sure Ill find a way around this soon.

A lot of files have changes. To upgrade, re-upload all the new files (you can skip the ones in the images and cache folder). Also reimport the product xml and revert your templates.
If you have custom fields, currently the phrases for them get dumped when importing so you need to edit each one and press save. Also, if you have any packages imported, you will need to do them again to get the templates.

26.06.2006

Have just released RC4d to address some issues trying to maintain this for both 3.5 and 3.6 branches of vBulletin. Primarily with missing subject/title fields.
I have also done some cleaning up, including improved RTL support in forumdisplay.

I would recommend everyone upgrade. Follow the standard upgrade proceedures of overwriting all your files and re-importing the product.xml.
Please note that reimporting the product.xml wipes out your custom field phrases. For right now, all you need to do is edit each field and click save. That will rebuild its phrase.
Also note that it wipes out your package import templates. I have updated each of the packages (links and release) with new files AND a pacakge called templates only which is perfect for upgrading GARS or the package as it only installs the templates.

27.08.2006

Seems that I uploaded an old version of geek/gars/mods/display/custom_fields.php into the upload package. It contained a bug that prevented text and large text custom fields from displaying right. If you are using text or large text custom fields, I would suggest downloading the package again and replacing your existing geek/gars/mods/display/custom_fields.php fiel with the new one.

Bad geek. baaaaaaaad geek.


nJoy

Ramses 08-23-2006 11:35 PM

1 Attachment(s)
Allright, installed as the instructions say and it's no big accident happend :)
But my opinion, there are some steps more necessary to reaching the gold status.
For example,
1. Custom textfields are again not showing on a review, title and description too. (you can see it in your review testing ground too, the custom field below the URL Thumb field)
2. If edit a review the Single Checkboxes are all ticked.
3. Now it is everytimes showing the "Submit the above ratings (box must be ticked to save ratings)" even if it is disabled in the acp settings.
4. If import the link directory it's showing below the description:
Warning: implode(): Bad arguments. in /includes/adminfunctions_template.php on line 676
(Stylevariablen) (CSS) (Replacement Variables)
Warning: Invalid argument supplied for foreach() in /includes/adminfunctions_template.php on line 780
(Einstellungen) Erledigt.
5. An error on the acp there's now an empty type (screenshot attached)
6. Users can rate a review although have in the review type settings: Users can post ratings No

Maybe it would be a good idea if you can set up all available custom fields on your review testing site (single checkboxes etc.) makes it easier to testing the system.

Thank you

waltercat 08-24-2006 01:00 AM

1 Attachment(s)
Thanks for the new release. I'm always happy to be a guniea pig and jump right in...

I can confirm that the custom text field dissapearance as well.

I am also still getting a text replacement (see attached) in place of the image even when it is diabled. The "Supress Header Image" is checked to yes, but the text is still replacing the image.

The byline issue is fixed. Thanks.

The preview in threadview is fixed too. Thanks.

Also, I noticed that some files that were in RC3 are not in RC4, like the snap.php an vbrelease.php. Is this okay?

The Geek 08-24-2006 02:01 AM

Yes, both come in the new packages in the add on section.

Ramses, sounds like the template may not be escaped in the links package. Ill check it out in the morning.
As for the review text box thing, that is for the URl, I just havent phrased it.
Ill double check the tick box and disapearing textbox fields, they all looked ok during testing.

absolutepunk 08-24-2006 08:03 AM

http://www.thevbgeek.com/tracker/ind...md=view&id=167

This error wasn't fixed.

I upgraded, and it still happens.

http://fire.absolutepunk.net/forumdisplay.php?f=166

The Geek 08-24-2006 08:48 AM

There was an issue where every time an item was edited, it simply added to the amount instead of editing the amount. THat is the only duplication I could do. If there are other reproduction steps that can be followed, please let me know!

absolutepunk 08-24-2006 09:01 AM

Quote:

Originally Posted by The Geek
There was an issue where every time an item was edited, it simply added to the amount instead of editing the amount. THat is the only duplication I could do. If there are other reproduction steps that can be followed, please let me know!

Uhm. It happens every time a user rates a review - it adds the amount to the user rating.

benj 08-24-2006 09:09 AM

got an error when adding term sets

Quote:

Database error in vBulletin 3.6.0:

Invalid SQL:
ALTER TABLE language ADD phrasegroup_GARS_4_phrases MEDIUMTEXT NOT NULL;

MySQL Error : Duplicate column name 'phrasegroup_GARS_4_phrases'
Error Number : 1060
Date : Thursday, August 24th 2006 @ 04:07:53 AM
Script : http://www.gars_admin.php?do=saveterm
Referrer : http://www./gars_admin.php?do=editterm
IP Address : 62.111.111.11
Username : Benj
Classname : vb_database

The Geek 08-24-2006 12:16 PM

Run the tools->clean orphans option. Did you try and import a package and get problems by chance?

Ramses 08-24-2006 12:33 PM

The rating system is still not working right. For example:
On the Link directory I changed the ratings to "Allow n/a" to yes.
If I create now a link and let the rating fields on "n/a" it is showing in the showthread "1 member rated average 0%" on the forumdisplay its showing "rated -10%" or another link on 182%.
Here on your links directory it's showing one thread rated 300% by 2 members
http://www.thevbgeek.com/forumdisplay.php?f=51

B.t.w. there's no more copyright of gars in this version in the footer (bug or feature? :) )


All times are GMT. The time now is 04:56 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.