The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   mysql error during restore (http://www.thevbgeek.com/showthread.php?t=1352)

clearchannel 04-13-2006 12:24 PM

mysql error during restore
 
I tried to restore my database after installing gars and received the following error message:

ERROR 1064 at line 1415: You have an error in your sql syntax. Check the manual that corresponds to your mysql server version for the right syntax to use near 'default smallint(6) NOT NULL default '0', allowhtml tinyint (4)

The restore stalls at the gars table. I tried to restore an earlier backup of the database before the install of gars with no problem.

What might you suggest.

Southpaw 04-13-2006 12:56 PM

Can you paste the whole query here? (line 1415)

clearchannel 04-13-2006 08:22 PM

How do I go about finding the query?

Southpaw 04-13-2006 09:06 PM

Open up the SQL file and then scroll to line 1415. Copy and paste the query here.

clearchannel 04-14-2006 11:48 AM

Can you recommend a program to open the database backup? It is of course a sql file. The file is 420 megs in size. I have tried notetab pro, windows word pad, and filemaker pro, they all seem to run out of memory before I can acually see the file.

Thank you in advance.

Southpaw 04-14-2006 02:21 PM

You can give notepad ++ a try: http://notepad-plus.sourceforge.net/uk/site.htm

clearchannel 04-14-2006 09:14 PM

Thank you for the suggestion. The query is:

CREATE TABLE gars_custom_fields (

Southpaw 04-14-2006 11:49 PM

The full query should look something like this right?
Code:

CREATE TABLE `gars_custom_fields` (
  `id` int(11) NOT NULL auto_increment,
  `title` varchar(50) NOT NULL default '',
  `description` varchar(250) NOT NULL default '',
  `required` tinyint(4) NOT NULL default '0',
  `maxlength` smallint(6) NOT NULL default '0',
  `displayorder` smallint(6) NOT NULL default '0',
  `editable` tinyint(4) NOT NULL default '0',
  `type` enum('input','select','radio','textarea','checkbox','select_multiple') NOT NULL default 'input',
  `default` smallint(6) NOT NULL default '0',
  `allowhtml` tinyint(4) NOT NULL default '0',
  `bbcode` tinyint(4) NOT NULL default '0',
  PRIMARY KEY  (`id`)
)


The Geek 04-15-2006 07:54 AM

Thats pretty odd. For now, just delete what southpaw posted above as that table isnt needed yet.

The Geek 04-15-2006 07:54 AM

IN fact, if everything else got created... and there isnt anything else after that bit... then you should be good to go.


All times are GMT. The time now is 09:13 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.