The vB Geek

The vB Geek (http://www.thevbgeek.com/index.php)
-   Geek Article and Review System (http://www.thevbgeek.com/forumdisplay.php?f=26)
-   -   GARS / GALS integration? (http://www.thevbgeek.com/showthread.php?t=4323)

trana 05-28-2008 07:16 AM

GARS / GALS integration?
 
Are there any methods to integrating GARS and GALS?

I'd like to have my GALS popups automatically created based on information I store in GARS. For example, I have a custom field in GARS that I would like to use for the text link, if the forum displays the text contained in the GARS custom field, it should display the link with the contents of another custom field. Basically it seems like a cron job that populates the GALS records with information from GARS.

Has anyone done anything like this?

Thanks!

Morgan 05-28-2008 05:27 PM

GARS and GAL can be linked via the Usergroup Permissions section of the GARS ACP settings (screenshot). If you tick the Enter GALs box, users can enter keywords and a description in the 'Autolink options' fieldset when posting an artcle that links back to their article (example: test).

trana 08-16-2008 03:47 AM

I finally got around to testing this.

When I edit a GARS post and put the value into the "link" section, I get a blank white page when I save my changes. Any idea what I might be doing wrong?

Thanks.

Morgan 08-16-2008 05:19 PM

When there is no error message, just a blank page, there is no clue for me to determine whether this is a GARS problem or a problem related to another modification. Here are some things to try if you receive another blank page:
  • Add a plugin to the gars_ignition_start hook with the following code and see if an error message shows on screen (how to add a plugin):
    Code:

    ini_set('display_errors', true);
  • Temporarily disable all modifications except GARS and see if the problem goes away.
  • Check your server error log for error messages.

trana 08-18-2008 03:42 PM

I added the plugin and received the following error:

Fatal error: Call to undefined method GAL_admin::add() in c:\Inetpub\wwwroot\forum\geek\gal\includes\gal_cla ss_admin.php on line 409

Morgan 08-18-2008 05:10 PM

That looks to be from an old gal_class_admin.php file. Grab the latest GAL package and reFTP the PHP files, overwriting the ones on the server.

trana 08-18-2008 11:48 PM

OK, I had a problem but I was able to fix it.

How do I add a link for a phrase with spaces?

I.E. xxxxxx yyyyy

Thanks.

Morgan 08-19-2008 05:29 PM

Just add the phrase to the keywords box, separating words/phrases with a comma, no beginning or ending comma in the box.

trana 08-19-2008 05:57 PM

Doesn't work. When I do that and save the article, the server times out:

Fatal error: Maximum execution time of 30 seconds exceeded in c:\Inetpub\wwwroot\forum\geek\gal\includes\gal_fun ctions_edit.php on line 200

I check in admincp and the GAL is indeed in there, meanwhile the server is doing an incredible amount of processing.

I check a thread 5 minutes later and see that every single space character in posts is linked to the GARS article.

Please let me know what I am doing wrong.

Thanks!

BTW: I put a comma at the end of the phrase to get it to take.

trana 08-20-2008 09:23 PM

Any ideas what I might be doing wrong? I'd really like to get this to work.

Thanks!


All times are GMT. The time now is 12:10 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.