PDA

View Full Version : security token message on reverted default style


Loco
03-31-2009, 03:27 PM
hi guys,
I have a small issue.
I'm adding a new style to our forum, using the default blue one built into vBulletin.
When I go to edit a thread in the link directory (using gars) I get the security token message

all the templates are the stock one, and have all been reverted.
What am I missing?

Thanks
-Brandon

Morgan
03-31-2009, 08:20 PM
What version of GARS are you using? If less than v.2.1.9, please see this (http://www.thevbgeek.com/showthread.php?t=4190) thread. The GARS v.2.1.8m and v.2.1.9 packages were updated last spring for CSRF Protection.

Loco
03-31-2009, 10:29 PM
ah, I think it was the newest one
I'm using "2.1.8" right now
I'll go upgrade

Thanks :o


*edit, It's been updated to 2.1.9 and I still get the token message when I edit one of the link directory post.
I'm not sure on the others.

I had exported all the gar's stuff before the upgrade, and imported it after.

Did I miss something?

Thanks

it's with this style (http://forum.vbulletinsetup.com/index.php?styleid=20) that I get the message
with my default style I have now, the orange and blue, it works great.

Loco
04-01-2009, 04:18 PM
any ideas on this?
this is the only thing holding me back from switching the default style to the vbulletin blue style, which is what I'd like to do.

It's working fine on my other styles, none of the gars templates are
"red" all show as reverted..

thx

*just tested, I'm now getting the error on the article pages as well. (on the default vbulletin style)
please help, it doesn't make since to me..
it works fine on my custom skin.. :(

Morgan
04-01-2009, 10:49 PM
GARS 2.1.9 accounts for security tokens so I don't think it is GARS, but it could be non GARS templates that need to be reverted, or it could be from a different modification. Try temporarily disabling all modifications, except for GARS, and see if the security token message goes away. If not, create a new style with no parent style and then view your forums with the new style and see if the security token message goes away.

Loco
04-02-2009, 05:08 AM
GARS 2.1.9 accounts for security tokens so I don't think it is GARS, but it could be non GARS templates that need to be reverted, or it could be from a different modification. Try temporarily disabling all modifications, except for GARS, and see if the security token message goes away. If not, create a new style with no parent style and then view your forums with the new style and see if the security token message goes away.

I'm using a new style with no parent :rolleyes:
That's the style I'm getting the message on, all the others (custom ones) work fine.

any other suggestions?

Morgan
04-02-2009, 05:35 AM
Go to the ACP -> vBulletin Options -> General Settings -> Add Template Name in HTML Comments -> Yes and then look at the HTML source on the edit page. Every HTML form needs to have the following between the <form> </forum> tags:

<input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />

Further all JavaScript POSTs need to have SECURITYTOKEN as part of the post.

More on security token error messages can be found at the following links:

http://www.vbulletin.com/forum/showthread.php?t=268862
http://www.vbulletin.org/forum/showthread.php?t=177013

If it's not the templates, then maybe it the JavaScript from some non GARS modification. If you search the GARS 2.1.9 files for HTML forms, and search the GARS 2.1.9 JavaScript for POSTs, you will find security token code in place.

Loco
04-02-2009, 05:04 PM
Thanks Morgan, I'll take a look and hopefully get it figured out :)

I think I got it working, thanks for that last post
idk how, but it helped me out :)

cheers man