PDA

View Full Version : Not allowed to se preview


Musika
03-24-2009, 02:56 AM
I tried to view either the html an the text version of the newsletter but /newsletter.php?id=1&prev=1 and /newsletter.php?id=1&prev=1&txt=1 showed me that I am not allowed to see the newsleter.

In the test folder I can see the newsletters but not on the preview window opend from the backend as Admin.

Im new on this and still testing this so what is my mistake?

Morgan
03-24-2009, 04:51 PM
Go to the ACP -> GAZ -> Newsletters -> click a newsletter link -> Usergroups allowed to subscribe, and make sure your usergroup is checked.

Musika
03-24-2009, 05:35 PM
It was all checked right. To test it I dechecked it and saved it and checked it again and saved it, but the problem still remains.

Morgan
03-24-2009, 08:42 PM
There are three of the following lines in the newsletter.php file:

print_no_permission();

Before the first one add the following:

echo 'a';
exit();

Before the second one add the following:

echo 'b';
exit();

Before the third one add the following:

echo 'c';
exit();

Then try another preview and let me know what letter you see on screen.

Musika
03-25-2009, 12:11 AM
None of the letters are shown, but the same message as before. As I am using the german translation I searched for the phrase and found out that $vbphrase[gaz_no_permission] is the shown message on english:
You do not have permission to browse the newsletter section. If you feel that you have reached this message in error, please contact the <a href="{1}" >administrator</a>

Musika
03-25-2009, 12:38 AM
A little bit strange.

I tried for the admin-group to activate the email-subscription an now newsletter.php is shown also for the other users with permission. Deactivatet the email-subscription and it continues working.

It seemed that even beiing checked the "ACP -> Usergroups -> GROUP Permissions -> Edit Permissions" had to be once be saved to activate them.

Strange but now it works.

Morgan
03-25-2009, 08:42 PM
Not sure I'm following post six, but there is the 'Can browse newsletter.php' setting in the ACP -> Usergroups -> Usergroup Manager -> Edit Usergroup that should be set to yes for those who can view the newsletter.php page on your site.

Musika
03-26-2009, 10:01 AM
After installing GAZ I looked at the Usergroup Manager and all users also the admin were allowed to see the newsletter, so I din' change anything.

After the "bug" or whatever, I checked also in the Usergroup Manager the email subscription for the admin and "saved" this setting. And from now on all the Settings in the Usergroup Manager worked.

It's like the settings are checked "on the paper" in the Usergroup Manager the first time, but not realy saved all over in the system.


Sorry for my bad english.

Morgan
03-27-2009, 01:48 AM
Thanks, I understand now. Not sure why that happened, but if it happens again, just let me know.

daisukem
07-31-2010, 09:59 AM
Hi Morgan.

Just letting you know that I have had the same problem and fixed by enabling ' allow Administrator to email friend'