PDA

View Full Version : Upgrading for GARS won't work! (I can't export my options)


FRAiD
12-06-2008, 07:14 PM
I was previously running on vBulletin 3.6x for XboxLiveArcade.com. Then I upgraded vBulletin (everyone knows that you should upgrade vBulletin first... then work your way out to the plugins) so I did. I'm now on vBulletin 3.74.

Now I can download the custom phrases from vBulletin via the language manager or whatever it's called. But when I go to the next step of downloading my custom fields... it gives me an error and says that feature is only available on vB 3.6

What can I do?

So I need to find out if I am going to just have to upgrade and add those fields back in or if there is a way to do it manually.

The fear is that if I just have to upgrade and add the fields back in that it will erase all of the current data in the reviews right now (That would happen right?).

I currently have a release date module I set up for the games, point cost, and screenshot modules.

See an example here:

http://www.xboxlivearcade.com/forum/strategy-sims-game-reviews/860-age-booty-review.html

I currently can't move GARS threads or create new ones because it gives me an error about a lack of security token otherwise I would have just stuck with the old version.

Please advise on how I should fix this.

Lizard King
12-06-2008, 07:23 PM
Upgrading Gars wont get you loose your custom fields. But you can take a backup of your custom fields from phpmyadmin

FRAiD
12-09-2008, 07:01 AM
Upgrading Gars wont get you loose your custom fields. But you can take a backup of your custom fields from phpmyadmin

I don't know how to do that. I downloaded my phrases from the language manager (ticked the box to include custom phrases)

But the problem I am having is being able to export my custom stuff from GARS that the instructions state must be removed because it will be erased if you upgrade your GARS.

Do you know what I'm saying?

(I don't understand php my admin... it makes no sense to me)

Morgan
12-10-2008, 04:55 AM
What version of GARS are you using? On what page are you receiving an error message, and what it the exact message?

FRAiD
12-11-2008, 12:52 AM
2.14

It's after I go to Import/Export GARS pick the options and then click export it says:

This facility only works for vB3.6x

Ideas? I don't want to have to go back into all my reviews and add the content again...

Morgan
12-13-2008, 03:51 PM
Version 2.1.4 is an old version, not sure I have a copy of it. What you can do is to take a database backup. You can do this via phpMyAdmin as Lizard King suggested or you can do this via the ACP -> Maintenance -> Database Backup.

If you use the ACP to backup, make sure the final line of your backup is the following:

### VBULLETIN DATABASE DUMP COMPLETED ###

If it is not that line, then the backup done via the ACP is incomplete.

When you upgrade GARS, it is the custom templates and phrases for GARS that get wiped out, not the custom fields, though you should take a backup anyway.

FRAiD
12-13-2008, 08:19 PM
So how do I ensure that if I just do an upgrade that all of the content I put into the various custom fields I created can be restored? like do I need to go in and manually recreate the custom fields in the order of which I made them?

i.e. custom field 2, 4 and 5 were screen shots.

Lizard King
12-14-2008, 06:12 AM
Best option for you is to install pypMyAdmin http://www.phpmyadmin.net/
You can also ask your host to install it for you. After you install it you can take a backup of the following tables :
gars_custom_fields
gars_custom_values
gars_module_set_details
gars_module_sets
gars_rating_questions
gars_rating_users
gars_ratingst
gars_terms

This will ensure that your gars templates will not get lost. If anything happens during upgrade you can restore them pretty easy.

FRAiD
12-19-2008, 06:15 AM
Is there anyone (Perhaps the owner) that could help with this aspect? When I renewed the license I assumed I could just follow the simple instructions without getting my hands too dirty in the land of PHP.

I get lost easily and have a habit of breaking things while I'm at it.

Lizard King
12-19-2008, 12:03 PM
I can asist you on Saturday night. I am on Gmt +2. Send me a PM to request contact info

FRAiD
12-23-2008, 10:10 AM
Shoot, I wasn't able to get on.

Can you PM me an email I can hit you up at perhaps?

FRAiD
12-27-2008, 09:53 PM
Perhaps you were busy during the holidays... are you free now?

Lizard King
12-29-2008, 02:25 PM
I received your PM but i wont be avaible at least a week. Very busy currently.

FRAiD
02-18-2009, 04:54 AM
Can you please help me with this upgrade?

I'll pay $20 via paypal for the trouble. I'm sure to you it'll be a piece of cake but to me I have no idea wtf you were talking about in your earlier posts.

Can you do it?

Please email me via neschris [at] gmail.com

Site owner or Lizard King... please help

Morgan
02-23-2009, 02:30 PM
To upgrade GARS please follow these (http://www.thevbgeek.com/geeki/index.php/Upgrading_GARS) steps. If you encounter any problems, please send a PM describing the problem.

FRAiD
02-24-2009, 04:13 AM
Morgan, did you read the earlier posts in the thread?

The steps never worked for me because I am using an old version of GARS and after upgrading to 3.74 it now says: "This facility only works for vB3.6x" when I try to export my old GARS settings.

The traditional steps don't work which is why I've been posting here in the forum. I paid for an updated license recently and the software is not allowing me to do the upgrade.

Can you please assist me ASAP?

Morgan
02-25-2009, 01:43 PM
Which of these (http://www.thevbgeek.com/geeki/index.php/Upgrading_GARS) steps doesn't work for you? The 'custom phrases' part? Did you add any custom phrases?

FRAiD
04-25-2009, 06:55 PM
Can I just pay you to upgrade it for me?

The installer won't allow me to do it the traditional method within the vBulletin admin CP.

Because as it is now the only option I feel I have is to uninstall the plugin and reinstall the new one and rebuild the entire thing; however, I have tons of reviews that I will lose and have to redo a ton of work if this is the case.

Can you please help if I pay you to upgrade it for me? Please contact me via email neschris [at] gmail.com (as I forget to keep coming back to this thread).

Morgan
04-26-2009, 12:53 PM
I'm sorry but I'm not offering upgrade/install services at this time, but perhaps someone else will come along and take you up on your offer. If you want to upgrade yourself, first make a database backup via the ACP -> Maintenance -> Database Backup.

Make sure the final line of your backup file is the following:

### VBULLETIN DATABASE DUMP COMPLETED ###

If it is not that line, then the backup done via the ACP is incomplete, so you can ask your host to make a backup for you.

Once the backup is complete, just follow these (http://www.thevbgeek.com/geeki/index.php/Upgrading_GARS) steps to upgrade GARS:

Download the latest version of GARS here (http://www.thevbgeek.com/glic.php)
Unzip the downloaded package on your PC
Upload the contents to the correct locations on your server
Import the product-gars.xml file via the ACP (do not uninstall, do allow overwrite)