PDA

View Full Version : Upgraded now getting db errors


smacklan
10-07-2008, 09:45 PM
Hi,

I recently upgraded to the latest version of GAL (was running a very old one) and what I did was uninstall the old version and files and did a fresh install of the new one. I am now getting this error when a user clicks on a hyper-link through GAL:

Database error in vBulletin 3.7.3:

Invalid SQL:
INSERT INTO vb3_geek_autolink_stats
(galid, typeid, m, d, y, script, forum, count, dateline) VALUES(
2, 1, '10', '07', '08', 'showthread', 13, 1, 1223352000);

MySQL Error : Table 'XXXXXXvb37.vb3_geek_autolink_stats' doesn't exist
Error Number : 1146
Request Date : Tuesday, October 7th 2008 @ 05:39:33 PM
Error Date : Tuesday, October 7th 2008 @ 05:39:33 PM
Script : http://www.vbskinworks.com/forum/autolink.php?id=2&forumid=13&script=showthread
Referrer : http://vbskinworks.com/forum/showthread.php?p=11745
Username : John
Classname : vB_Database
MySQL Version : 5.0.51a-community

Any help would be appreciated :)

smacklan
10-07-2008, 10:59 PM
Just another bit of info, that table does exist in my DB and does have the correct name however I do use the table prefix of vb37_

Morgan
10-09-2008, 04:51 PM
ReFTP all the GAL files. The query looks to be coming from an old file, as the query is trying to get results from the geek_autolink_stats table, a table that is not present in the new GAL code. From that error message, it looks like the old autolink.php file is still on the server.

smacklan
10-09-2008, 06:11 PM
Thanks Morgan, I will scan for old files and see what that does :)