PDA

View Full Version : GAB Install on 3.7.x plus Fix


Mythotical
03-29-2008, 08:08 PM
If you receive this error:

Invalid SQL:

SELECT profilefieldid, title
FROM profilefield;

MySQL Error : Unknown column 'title' in 'field list'
Error Number : 1054

Then do the following:
Open GAB_admin.php
Find:
if (substr($vbulletin->options['templateversion'],0,3)=="3.6")

Replace with:
if (substr($vbulletin->options['templateversion'],0,3)=="3.6" OR "3.7")

Fixed and now you will have a working GAB on 3.7.x

Morgan
04-01-2008, 06:01 AM
Thanks, the current version of GAB already accounts for 'templateversion' so anyone running GAB 2.0.x and up need not make that change.

Mythotical
04-01-2008, 01:57 PM
Actually this is for the new version unless you added this earlier after the new release.

Morgan
04-02-2008, 04:11 PM
GAB_admin.php from GAB v.2.0.2 contains the following. Don't recall when it was added.

if (substr($vbulletin->options['templateversion'],0,3) >= "3.6")