PDA

View Full Version : Problem with Turkish Characters


batox
02-09-2008, 04:15 PM
hi,

Turkish letters (şığç) make problems..

to example ş becomes in database as 351 stores..

How can I eliminate this problem?

Morgan
02-09-2008, 05:41 PM
phpMyAdmin -> choose database -> choose table -> click Operations tab -> set Collation to whatever character set you wish to use - if not sure, look at the Collation value from another table that stores characters the way you want.

Also see http://www.vbulletin.com/forum/showthread.php?t=259250 for other suggestions.

batox
02-09-2008, 06:04 PM
these problems develops if I over admin panel one word register

if I register over phpmyadmin manuel word, it is indicated correctly.. but none autolink with Turkish characters..

you can please try this word here: baþý

Morgan
02-09-2008, 07:37 PM
It is the ISO-8859-9 that makes baþý appear on screen as the word başı but if you type the word başı it is saved on this site as ba& #351;& #305; (without spaces) because this site uses ISO-8859-1 and not ISO-8859-9 so no match is found.

If you are seeing ba351305 instead of başı in the ACP, then the page encoding is not correct. Make sure you are using ISO-8859-9 when entering keywords via the ACP. Also, as your site is ISO-8859-9, try latin5_turkish_ci as the Collation on the gal database table.

The next thing to do is try a different regular expression. Here are a few that you can try. Once you've added them, go to Categories and select a new regular expression from the drop down menu, and then run both 'Cache' options in the maintenance section:

#(($1)(?=[^>]*<)(?![^<]*</))#im

#(\b($1)(?=[^>]*<)(?![^<]*</))#im

#(\b($1)\s(?=[^>]*<)(?![^<]*</))#im

#(\s($1)\s(?=[^>]*<)(?![^<]*</))#im

Given different encodings, post formats, PHP settings, etcetera, it is difficult to provide a one size fits all regular expression, so you might need to try different ones until you find one you prefer, though the 'standard' regexp may work also.

batox
02-09-2008, 08:07 PM
I made ISO-8859-9 now and everything is ok now

thanks so much Morgan!