PDA

View Full Version : HTML special characters - $ and " being parsed to & and "


rtysmith
01-28-2008, 02:06 AM
HTML special characters

$ and " being parsed to & and "

I'm having an issue where HTML special characters are not displaying correctly. In looking at vbulletin.com support forums, I found: That problem is due to the post being double parsed for HTML special characters.

When I turn off GAL, it stops. I also have VBSEO installed. Any ideas?

See : http://forum.carseatdata.org/fitting...an-maxima.html

Tyler

Morgan
01-28-2008, 05:42 AM
Something else is going on. Looking at the HTML source, there is the following, where a link is being inserted all over:

58
<a rel="nofollow" href="http://forum.carseatdata.org/autolink.php?id=21&amp;forumid=19&amp;script=showthread" target="_blank" class="gal" id="gal_21_1345_683"></a>
&
<a rel="nofollow" href="http://forum.carseatdata.org/autolink.php?id=21&amp;forumid=19&amp;script=showthread" target="_blank" class="gal" id="gal_21_1345_684"></a>
quot
<a rel="nofollow" href="http://forum.carseatdata.org/autolink.php?id=21&amp;forumid=19&amp;script=showthread" target="_blank" class="gal" id="gal_21_1345_685"></a>
;
<a rel="nofollow" href="http://forum.carseatdata.org/autolink.php?id=21&amp;forumid=19&amp;script=showthread" target="_blank" class="gal" id="gal_21_1345_686"></a>

Go to the ACP -> Geek Auto-Linker -> Display and mouse over each keyword until you find the one where do=editgal&id=21 is in the link.

What is that keyword?

rtysmith
01-29-2008, 02:02 PM
Hi, just to make sure the url is:

forum.carseatdata.org/fitting-3-seats/435-volvo-xc90-and-nissan-maxima.html

The keywords that trigger the GAL are:

hbb, HBB, Hbb, Highback booster, highback booster, high back booster

Morgan
01-29-2008, 05:37 PM
What regular expression are you using for the category with those keywords?

Tip: the default regexp is case insensitive so no need for multiple cases.

rtysmith
01-29-2008, 06:25 PM
Thanks for the tip.

I am too afraid of regular expressions to touch them - so I've made no changes there - just "standard"

If it would have help to have admin access to my board, just let me know.

Morgan
01-29-2008, 07:42 PM
It would help, thanks.

rtysmith
01-29-2008, 07:43 PM
sending via PM

Morgan
01-29-2008, 08:15 PM
GAL ID 46 was latch, LATCH, and after changing it to latch all in well. Make sure to not have the keywords end with a comma. ;)

rtysmith
01-29-2008, 08:26 PM
Sweet - you rock - good find. Thanks for the help!