PDA

View Full Version : Problem with extended inline style info


pixie
06-14-2007, 02:21 PM
Although I changed the path of the .tcat-images (under extended inline style info)to an absolute one, these images are never included in my newsletter. And yes, I disabled 'Prefix paths'. How can I solve this?

Thanks! :)

The Geek
06-15-2007, 06:17 PM
Are they broken links or are you using an email reader that wont use css images? (ie hotmail and gmail)

pixie
06-16-2007, 05:06 PM
No, the links are all OK and I'm not using any reader. I simply open the .html-file from my FTP dumpfolder, after I sent the newletter in testmode and it does not load the .tcat, .thead, etc.

The Geek
06-16-2007, 05:43 PM
can you forward one on to vbgeek at thevbgeek dot com?

pixie
06-16-2007, 07:08 PM
OK, I have now setup a newsletter-style, which I like and which does not include any images. :)

The version sent via Mail is absolutely OK and I want to keep it like that. Anyway, the problem I'm currently facing is that the online version still shows the .tcat, .thead images, which does not fit the new style at all.

How can I disable these images for the online version envoked by the script? (www.mydomain.com/gazette.php)

Thanks!

The Geek
06-19-2007, 01:37 PM
Im not sure I understand... They should look the same? Can you provide me with a link?

pixie
06-19-2007, 01:58 PM
Well, I'd like both versions to look exactly the same. The newsletter, which was actually sent via E-Mail and the online version in the archive.

Right now, the latter shows all images including .tcat, .thead, while the first one does not. Therefore both styles differ.

Please take a look here: www.pixelplausch.de/pixelpost (http://www.pixelplausch.de/pixelpost)

This version (right) shows all images but the text of category headers is not readable, because I had to set it to a different color in the E-Mail version (left) where no images are displayed.

http://www.pixelplausch.de/_anhaenge/gaztrouble.jpg

Sorry for the confusion! ;)

The Geek
06-19-2007, 02:03 PM
Ill need to see an email version of it to compare. Technically, they should be exactly the same.

pixie
06-19-2007, 03:01 PM
Well, I sent you the e-mail version on sunday. Forwarding in Thunberbird does not seem to work. The message is always converted to plain text before sending.

Maybe I Missed a setting somewhere?! Will try again.

Thanks! :)

The Geek
06-19-2007, 03:25 PM
Have you refreshed the layout since you tweaked the inline style?

pixie
06-19-2007, 03:33 PM
Yes, multiple times...

The Geek
06-20-2007, 04:11 AM
The problem is that your css for the email has several background images that use relative paths. Since these paths are invalid when reading the email, they dont appear, however online they do appear. Since the background is black, it hides your black text making the online version look odd.

Do you have the prefix paths on? Turn them on and rebuild the layout. Saying that, GAZ cant always change all of your css inline paths. You may need to edit the styles css and change any relative paths to the full ones.

The problem then will be that your email's will appear with black on black if and when the images get downloaded (hotmail and gmail wont download them).

What you really need to do is have your tcats inline style information match the look without images. In other words, if you normally have a black gradient in there, the background cololour should be black so it looks similar with or without the images. Therefore your text would need to be a different colour.

Hope that makes sense.

pixie
06-20-2007, 09:05 AM
OK, so it is recommended not to worry about images at all, right? I can live with that! ;)

Thanks for your time and thanks for your tools all of which are really great!! :D

-=BFC=-Tekram
07-05-2007, 08:02 AM
Ich habe das selbe Problem, wie hast Du es gelöst? Wäre Dir dankbar für eine Antwort