PDA

View Full Version : Custom Newsletter and Custom Module Set Problem


Dr. Bantham
05-20-2007, 09:54 PM
I have created a custom newsletter which I want to have reference a custom module set. The idea is to have an event notice which does not include all of the other modules, but instead features a singular notice.

The problem occurs when I define the module set from the drop-down box while editing the custom newsletter. It allows selection of the custom module set, but it does not maintain the setting upon save, and instead reverts back to the default module set.

The Geek
05-21-2007, 08:43 AM
What is the code for your module?

It may help to look at the structure of the existing modules as it is pretty defined :)

Dr. Bantham
05-23-2007, 01:21 AM
The module is set up as follows:

Title: Special Announcement
Description: Single Event Message
Page Type: HTML
Top: Info Block
Username:
Show Avatar: No
Title: Sample Title
HTML/BBcode: Sample Content

Note that I have no other blocks defined, as I wish for this to be the only content. I have also tried Simple Text Block. If I set this module up in the Weekly Newsletter or the new Special Announcement newsletter I created, it does keep the setting upon saving, and reverts back to Default Module Set.

Is this what you you mean when you asked for the module code?

The Geek
05-23-2007, 06:37 AM
I was assuming that you had created a custom module? Is this not the case?

Dr. Bantham
05-23-2007, 09:55 AM
By "custom module" I meant clicking on the "Add New" button with the Modules section of GAZ in ACP. I filled in the fields per the settings above. I never created custom code or files.

The Geek
05-23-2007, 11:58 AM
ok, Ill check it out

Dr. Bantham
05-27-2007, 01:03 PM
RC4 fixed this. Many thanks!