PDA

View Full Version : Maintaining Backward compatability


The Geek
09-28-2005, 08:44 PM
I'm sitting here plugging away on the next iteration of GeekMart. I know I promised something a couple weeks ago - however I poured all my time into getting GARS where it is so I have a good excuse.

Currently, the only vB3.0x item I have on here is a back ported version of GeekMart. Essentially I am coding it to be vb.3.0x and vb3.5x compatible.

Basically, Its doing my head in and I find myself spending more and more time re-sanitizing variables and putting in workarounds to try and keep the code duo system compliant. I was going to do this until RC stage and then decouple the two so I could optimize both however I just don't know if I can be asked.

Seriously now... How many of you are in need of a vB3.0x GeekMart? I know there are a few out there, but coding for both is going to take my a lot longer than coding for one system. Hell, that means by the time Gold comes round most people will be on 3.5x anyway.

Just after your feedback.

BTW: Its coming along realllll nicely. A lot more features.

nJoy

Walim
09-28-2005, 09:14 PM
Hello

I'm waiting Geek Article and Review system That What i'm intersted :)

The Geek
09-28-2005, 09:23 PM
Thats in Beta 3 right now. I wouldn't think it will take much longer to get there. However while results come in from beta testing, I'm busying myself with GeekMart ;)

Fleabag
09-28-2005, 11:20 PM
I'd say drop it Geek. The lack of response is testament to the fact that there isn't demand for the 3.0.x version. In a software world if you want the latest products you have to keep up with everything that goes with it... I think 3.5 is stable enough for anyone to migrate now - personally I don't see any reason not to. Just my 2 cents. :)

The Geek
09-29-2005, 11:14 AM
Yea, think im going to. There was only my 3.0x site I needed compatability for and 1 other user that I know of. Im looking at upgrading within the next week so it seems silly to work so hard at keeping it compatable for both.

TheComputerGuy
09-29-2005, 06:26 PM
I support the 3.5 vote. 3.5 allows for so much more expandability and complete the Geek Swiss Army Knife!

KTBleeding
09-29-2005, 07:43 PM
Honestly, I would say go for the 3.5 development as well. Gold was released recently, and I'm sure everyone will switch him soon enough. Plus, having a hack like this only available for 3.5 will force people to upgrade to 3.5, which is a good thing. :)

I was nervous to upgrade at first, but I can't wait until I get my 3.5 skin ready for launch. I don't want to work on 3.0.X anymore.

TheComputerGuy
09-29-2005, 11:52 PM
I agree KT. 3.5 is so much easier on the Admin

sketch42
10-01-2005, 06:03 AM
i dunno if im the only one waiting for this on 3.0.x but i can not upgrade to 3.5 as i have many custom hacks {hacks that i have paid to people to write } on my site, now im all for coding for 3.5 but if the original intention was to do for both than please do.. release the 3.5 first if you feel that its easier.. but please dont drop the 3.0.x
personally i dont care if the 3.0.x has crazy bells and whistles i would be satisfied with just the basics but in the end you need to do whats best for you and your sanity so.. really its up to you

Sony
10-01-2005, 06:02 PM
I would go 3.5+ and concentrate on that, most people will eventually upgrade like it happen with 3.x
One version will keep the code cleaner and speed up your work and testing of betas

sketch42
10-02-2005, 12:38 AM
time to look for another coder to pay..... it seems

The Geek
10-02-2005, 12:59 AM
How much longer you planning on staying with the 3.0x series? What hacks do you have that havent been or cant be ported over? Id love to help - and maybe once GM goes gold (or cglose to it) I can back port it but other than you - I have no customers or requests for a 3.0x version.

Keep me up to date. Ill do what I can to help